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Working with the Browser 

What is the Browser? 
The Beyond 20/20 Browser is a Windows-based program used to browse Beyond 20/20 
tables and extracts. 

Browsing is a collective term that is used to describe the dynamic way you look at and 
manage the information the Browser presents. Browsing begins the moment you start the 
Browser, and it ends as soon as you are satisfied that your view contains the information you 
are looking for.  

In general, browsing involves: 

• Opening one or more tables or extracts. 

• Examining their contents. 

• Identifying the relevant data. 

These activities are carried out from within the Browser window. The Browser window 
provides the tools you need to browse tables and extracts and work with the information in 
them. It contains features that are common to all Microsoft Windows applications.  

Beyond 20/20 Browser Files 

Table File (*.ivt) 
This file holds all the data and textual information associated with a table, as well as 
information on how the table is displayed. 

Extract File (*.ivx) 
An extract file is used to create a personalized table. It includes textual information: the 
name, type, description, and category of the extract, and the dimension definition file 
references for each source field in the extract. 

Dimension Definition File (*.ivd) 
A dimension definition file defines a dimension of a table or a source field of an extract. It 
generally contains information about the dimension (i.e., its name, description and type), and 
the codes and labels associated with the items of the dimension. It can optionally contain 
notes, a hierarchical structure, language specific information, or a link to a map file. 
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When an extract is created, a dimension definition file is generated for each source field in 
the extract. In addition to the information described above, a dimension definition file 
associated with an extract contains the data associated with each item in the source field. 

Browser Menus 
The Browser commands have been logically grouped into menus according to their purpose. 
The menu bar is dynamic and reflects the menus that are appropriate to your current view. 

The File, Edit, Window, and Help menus are similar to those in most Windows-based 
applications and provide access to basic Windows functions. Additionally, the File and Edit 
menus provide you with access to unique Beyond 20/20 features, and the Window menu's 
Preferences command allows you to customize the user interface. 

The commands in the View menu control what is shown in your current view. You can create 
map and chart views using the View menu. The Dimension and Item menus assist you in 
performing tasks specific to dimensions and items. 

The Data menu concentrates on tasks that affect the output of the table creation process and 
contains commands that initiate the table creation process. 

Note:  A context menu is one that is shown when you click the right mouse button from the 
active window. The Browser incorporates context menus in the current view when 
appropriate, and their contents vary depending on the current activity. 

The Toolbar 
The toolbar consists of the Active Dimension box, the Previous and Next Item buttons, and 
the toolbar buttons. 

Active Dimension Box  

  
The Active Dimension box identifies the dimension that is currently selected. A dimension 
must be active if you want to do something with it (such as sort, search, view, or change 
labels). To set the active dimension, select the desired dimension from the drop-down list 
box. 

Previous Item and Next Item Buttons  

  
The arrow buttons on either side of the Active Dimension box are called the Previous Item 
and Next Item buttons. They let you step through the items in a dimension. 

Clicking the Previous Item or Next Item button when the column or row dimension is active 
moves the cursor along the column or row. When the active dimension is positioned in the 
dimension bar, the buttons are used to sequentially display the data associated with the next 
item. 

Toolbar Buttons 
Toolbar buttons provide you with shortcuts to some of the most often-used menu commands.  
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Button Name Function 

 
Open Lets you select and open a table or an extract by entering its 

location and file name. Clicking the Open button does the 
same thing as choosing Open from the File menu. 

 
Find Opens the Find dialog box which lets you search for, identify, 

and open a table or an extract. Clicking the Find button does 
the same thing as choosing Find from the File menu. 

 
Tile Arranges all open documents into a tile pattern. Clicking the 

Tile button does the same thing as choosing Tile Vertical 
from the Window menu. 

 
Next Label When the active dimension contains two or more fields, the 

Next label button moves from one field to the next, displaying 
the new text for each item as it steps through the fields. 
Clicking the Next Label button does the same thing as 
choosing Change Labels from the Dimension menu. 

 
Print Prints the active view. Clicking the Print button does the 

same thing as choosing Print from the File menu. 

 
Search Lets you enter text or a numeric range that the browser will 

search for in the active dimension. A search can either 
expand or reduce the number of items in the view, or it can 
find an item. Clicking the Search button does the same thing 
as choosing Search from the Dimension menu. 

 
Sort Sorts the items in the active dimension in ascending or 

descending order. Clicking the Sort button does the same 
thing as choosing Sort from the Dimension menu. 

 
Display Active 
Dimension 

Opens a window on the field information associated with the 
active dimension. Clicking the Display Active Dimension 
button does the same thing as choosing Dimension from the 
View menu. 

 
Display Chart Creates a chart view based on the items you select in a table 

view. Clicking the Display Chart button does the same thing 
as choosing Chart from the View menu. 

 
Display Map Displays a map view that corresponds to the active table 

view. Clicking the Display Map button does the same thing as 
choosing Map from the View menu. 

 
Load Data Performs the Load Data operation to create a table. Clicking 

the Load data button does the same thing as choosing Go 
from the Data menu. 

 
Change 
Language 

Simultaneously changes the language and the user interface 
of a multilingual table.  

The Document Window 
The Browser window changes, depending on whether you are working with a table or an 
extract. 

This Browser window shows the four-dimensional demonstration table, PRODUCTS. The 
REGION dimension is along the rows and the TIME PERIOD dimension is across the 
columns. The UNITS and the COOKIE TYPE dimensions are positioned in the dimension 
bar. 
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This Browser window shows an extract: 

 
Each document window has its own title bar, Minimize and Maximize buttons, and vertical 
and horizontal scroll bars, regardless of whether an extract, a table, a chart, a map, or a 
dimension view is displayed in it.  

Row Dimension Area 
The row dimension area is the area where source field tiles can be positioned to create the 
row dimension. 
In an extract, this area is initially blank. To create a table, a source field tile is dragged into 
the row dimension area and consequently becomes the row dimension. 
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Column Dimension Area 
The column dimension area is the area where source field tiles can be positioned to create 
the column dimension. 
In an extract, this area is initially blank. To create a table, a source field tile is dragged into 
the column dimension area and consequently becomes the column dimension. 

Dimension Bar 
The dimension bar is where source field tiles can be positioned to create dimensions other 
than the column and row dimensions. 
In an extract, this area is initially blank. To create a table, a source field tile is dragged into 
the dimension bar area and consequently becomes a dimension in the dimension bar. 

Source Field Bar 
The source field bar contains a list of source field tiles from which you can create a table. It 
appears, when appropriate, down the right-hand side of the screen. A small number sign in 
the lower left corner of the source field tile indicates a numeric source field. The source field 
bar can only be seen when an extract is open. 

Status Bar 
The status bar provides information about the active view and the current or selected item(s). 

Scroll Bars 
Vertical and horizontal scroll bars appear in the document window when columns and rows in 
a maximized table view expand beyond the size of the workspace. Use them to scroll to 
items you cannot see, or to scroll to any windows or icons that have been moved outside of 
the workspace. 

Window Details 
This Browser window shows a sample table.  
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This table has the following dimensions: 

• Units and Project are in the dimension bar. Both have summary icons to indicate that 
metadata is present. You can click the icons to read the summaries. Project shows the 
group Mammography Screening, whose name is bold and underlined to show that it 
defines a group, and a drill back arrow, which indicates that you have previously drilled 
down into a group. Clicking the arrow will show the previous group view. 

• Date is across the columns. 

• Region is along the rows. It has a summary icon and one of its items, United States, 
defines a group. 

• The mouse cursor is hovering over the data cell for New York, January 1997, which 
contains two footnote indicators and a missing value indicator. You can read the footnote 
and missing value explanations in the popup. 

Selecting Items 

The normal cursor 
This screenshot of a Browser window shows a table with a dimension called Region. Region 
has been selected by single-clicking in its tile and the mouse cursor is normal. 
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The hand cursor 
Pointing at a drill back arrow, a summary icon, or a bold and underlined group name changes 
the cursor into a hand.  

When the cursor is a hand: 

• Single-click a summary icon to read the summary. 

• Single-click a group name to drill down into the group and show its members. 

• Single-click a drill back arrow to see the previous group view. 

Note: If you click an object but move off it before you release the mouse button, the action is 
cancelled and the cursor becomes a cross for selecting or dragging. 

Note: If you press and hold the Shift or Control key, the cursor is prevented from turning into 
a hand. It becomes a cross for selecting or dragging. 

The cross cursor 
If you point at a tile but not at any objects, the cursor turns into a cross for selecting and 
dragging. This Builder window shows the cursor as a cross pointing at Toronto: 
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When the cursor is a cross: 

• Single-click to select an item. 

• Click in a tile and drag over other items before you release the mouse button to select 
multiple items.  

• Press and hold the Control key to select separate items. While the Control key is pressed 
the cross cursor is prevented from becoming a hand so that you cannot inadvertently 
select a summary icon or drill down into a group. 

• Press and hold the Shift key to select separate items and all the items in between them. 
While the Shift key is pressed the cross cursor is prevented from becoming a hand so 
that you cannot inadvertently select a summary icon or drill down into a group. 

Changing the Language of a Table 
A multilingual table is one whose descriptive components are available in more than one 
language. 

When a multilingual table is initially opened, it is displayed in the language of preference as 
defined in the Preferences dialog box. The status bar always indicates the current language 
of a multilingual table. 

The following list defines the language abbreviations used in the status bar: 
 

Abbreviation Language 

Dan Danish 

Deu German 

Eng English 

Esn Spanish 

Fin Finnish 

Fra French 

Isl Icelandic 

Ita Italian 

Nld Dutch 

Nor Norwegian 

Ptg Portuguese 

Sve Swedish 

¾ To view a multilingual table in one of its alternate languages: 

Do one of the following: 

• From the View menu, choose Change Language. 

• Press F9. 

 Note:  Subsequent selections of the Change Language command or function key display 
the table in its next available language. 
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Changing the Table and User Interface Languages 
 The Change Language button on the toolbar changes the language of a multilingual 

table and the user interface. 

Note:  The multilingual table must contain descriptive components in two or more languages. 
To view any additional languages, press F9. 

Displaying a Table Title in the Window Header 
You have the option of displaying either the one-line table title or the table name in the title 
bar of the table view. By default, the one-line title is displayed. 

¾ To display the table name in the table view header 

1. From the Window menu, choose Preferences. 

 The Preferences dialog box appears. 

 
2. Clear the Display Table Title in Document Window Title Bar check box. 

3. Click OK. 

  The table name is displayed in the title bar of the table view. 

Selecting Colors for a Table View 
You can change the color of the dimension tiles and item headings. You can also select a 
color to indicate which tile and/or heading is currently active. 

¾ To select a dimension color and a selection color 

1. From the Window menu, choose Preferences. 

2. In the Dimension Color box, select a color for all tiles and headings. 

3. In the Selection Color box, select a color to represent selected objects. 

4. Click OK. 

  The table view contains the colors you selected. 
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Resizing Dimension Tiles and Headings 
When a table is initially opened, the width of the row headings are automatically adjusted to 
accommodate the longest item. However, when you change labels or switch dimension tiles, 
the space provided in a heading may be too wide or not wide enough to accommodate the 
text in the heading. 

¾ To alter the width of a heading 

1. Click on one of the following: the border of the first heading in the column dimension, the 
border of any heading in the row dimension, or the border of a tile in the dimension bar. 

2. Do one of the following: 

• To increase the width of the heading, drag the border to the right. 

• To decrease the width of the heading, drag the border to the left. 

 As you drag the mouse, shadow line(s) indicate how far the border has moved. 

3. Release the mouse button. 

Tiling and Cascading Document Windows 
The Browser can display document windows side-by-side in a tile arrangement, or one 
behind the other in a cascade arrangement. Arranging the windows this way lets you see 
how many windows are open and provides immediate access to all of the windows. To 
access a document window, click on it to make it active. 

¾ To tile all document windows 

1. Do one of the following: 

•  Click the Tile button on the toolbar. 

• From the Window menu, choose Tile Vertical or Tile Horizontal. 

The Browser arranges all of the document windows either side-by-side (vertically) or one 
above the other (horizontally). 

  

Tip:  You can automatically tile all chart and map windows. From the Window menu, 
choose Preferences and select the Automatically Tile Windows on Creation check box. 

¾ To cascade all document windows 

1. From the Window menu, choose Cascade. 

The Browser arranges all of the document windows one behind the other, leaving the title 
bar of each showing. 
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A Quick Tour of the Browser 

Working With Tables 

Finding and Opening a Table 
When you first start the Browser, the Find dialog box is automatically displayed to provide 
you with the easiest and quickest way to find and open a table or an extract. 

Note:  You can control whether the Find dialog box automatically appears when you open 
the Browser. To suppress the display of the Find dialog box, from the Window menu, choose 
Preferences, and clear the Display the Find dialog box on Start Up check box. 

 

¾ To open a table 

1. In Categories, confirm that the ‘Beyond 20/20 Demonstration Tables and Extract’ 
category is selected. 
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Some table names and an extract name are displayed in the Files box. They are 
assigned to the Beyond 20/20 Demonstration Tables and Extract category. 

2. In the Files box, select ‘PRODUCTS.’ The full table title is displayed in the Title area. 

3. Click Summary for an extended description of the table. 

4. Click Cancel to return to the Find dialog box. 

5. Do one of the following: 

• Double-click on ‘PRODUCTS.’ 

• Click OK. 

The PRODUCTS table appears. The window fills the workspace; the title of the table is added 
to the information in the window title bar. 

Browsing the Table 
Browsing Through Items 

The Next Item and Previous Item buttons on the toolbar can be used to sequentially display 
the items in the active dimension. If the column dimension or row dimension is active, the 
cursor simply moves along a column or row. However, if a dimension in the dimension bar is 
active, the Browser displays the data associated with the next or previous item in that 
dimension. 

¾ To browse through items 

1. Do one of the following: 

• Click on the COOKIE TYPE dimension tile. 

• In the Active Dimension box, select COOKIE TYPE. 

2.  Click the Next Item button on the toolbar. 

The view changes to show the data associated with the next item, ‘Ginger Zings.’ 

3. Continue clicking the Next Item button. 

There are six items in the COOKIE TYPE dimension. Each time you click the Next Item 
button, a new view for a single item is displayed. 

Opening a Dimension View 
Dimensions comprise a number of fields: the code field, data field, and optionally, one or 
more label fields. If you are not familiar with the fields that make up a dimension, open a view 
of the dimension to determine its contents. 

When you open a dimension view, the Browser displays the code field and the label fields 
associated with that dimension’s items. Data cannot be seen in a dimension view; it can only 
be displayed in a table view. 

¾ To open a dimension view 

1. Click on the COOKIE TYPE dimension. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

The COOKIE TYPE dimension view appears. 
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Changing the Labels of Dimension Tiles and Headings 
The symbols and/or text that make up a dimension’s codes and labels can be displayed (one 
field at a time) in a dimension tile, or in the headings associated with the column and row 
dimensions. As long as the display of a label field has not been suppressed by the Builder, 
you can choose which field the Browser displays in the table view. 

¾ To change labels 

1.  Click on the REGION dimension. 

2.  Do one of the following: 

•  Click the Next Label button on the toolbar. 

• From the Dimension menu, choose Change Labels. 

The Browser displays the next available label field for the REGION dimension. 

When the active dimension contains two or more fields, subsequent selections of the 
Change Labels command or toolbar button displays the next label field. 

Switching Dimensions 
You can have two dimensions change places in the table view. You do this by dragging and 
dropping one dimension tile on top of another dimension tile. 

¾ To switch two dimensions 

1. Click on the COOKIE TYPE dimension tile and hold down the left mouse button. 

2. Drag and drop the tile on top of the TIME PERIOD dimension tile, or over any of the 
headings in the column dimension. 

The first item in the TIME PERIOD dimension, Jan1991, is displayed in the dimension 
bar. All of the items in the COOKIE TYPE dimension are displayed in the column 
dimension. 

Tip:  You can switch any single item from the column or row dimension into the dimension 
bar  by dragging and dropping its heading into the dimension bar.  
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Nesting Dimensions 
You can display more than one dimension along the columns or rows. You do this by 
dragging and dropping a dimension tile into the column or row dimension area. 

 

¾ To nest a dimension 

1. Click on the TIME PERIOD dimension tile and hold down the left mouse button. 

2. Drag the tile over the upper border of the headings in the column dimension. 

 The upper border of the column dimension area is highlighted. 

3. Drop the dimension tile. 

 A new set of headings is created in the table view where you dropped the tile. 

Searching Items 
In a typical scenario, you may want to look at a specific aspect of data. To do this, you can 
use the Search command. 

In this exercise, you will use the Search command to determine which regions enjoy the 
greatest volume of cookie sales. 

Position the TIME PERIOD dimension in the column dimension area, and the REGION 
dimension in the row dimension area. Nest the COOKIE TYPE dimension below the TIME 
PERIOD dimension. Select the Revenues($000) item in the UNITS dimension located in the 
dimension bar.  

To compare the regions that have the highest volumes of sales, specify a minimum revenue 
figure, and direct the Browser to reduce the display of items to show items that are higher 
than the specified minimum. 

¾ To search items 

1. Click on the REGION dimension tile. 

2. Click on a cell in the All Cookie Types column. 

3. Do one of the following: 
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•  Click the Search Dimension button on the toolbar. 

• From the Dimension menu, choose Search. 

The Search dialog box appears. 

4. In the Field box, confirm that ‘Data’ is selected. 

5. In the Type of Selection area, confirm that the Reduce option button is selected. 

6. In the Minimum box, enter ‘700.’ 

 
7. Click OK. 

The revenues that are lower than the specified minimum are hidden. The status bar reads 
that 7 out of 15 items in the REGION dimension are displayed. 

Tip:  You can search the code field or any of the available label fields. The Browser can 
decrease or increase the number of items on display, or it can find and display the item 
you specify.   

Sorting Items 
You can sort items according to the value of their data.  

In this exercise, you will sort the items in the TIME PERIOD dimension to see which months 
are associated with the highest sales revenue. 

¾ To sort items 

1. Click on the TIME PERIOD dimension tile. 

2. Do one of the following: 

•  Click the Sort Dimension button on the toolbar. 

• From the Dimension menu, choose Sort. 

The Sort dialog box appears. 
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3. In the Field box, select ‘Data.’ 

4. In the Sort Options box, select ‘Decreasing.’ 

5. Click OK. 

The Browser sorts the items in the TIME PERIOD dimension in decreasing order. The 
cursor remains fixed on the item it was on prior to the sort. 

The greatest single revenue associated with the All Cookie Types item is displayed in the 
left-most column, and the remaining data values are sorted in decreasing order as you 
scroll right. If you scroll to the right, past the first items in the TIME PERIOD dimension, 
you will see that the three best months are Mar1994, Dec1993 and Nov1993. As you 
scroll, the position indicator in the window displays the codes of the items in the TIME 
PERIOD dimension as you scroll past them. 

Changing Group Levels 
The items in the REGION dimension are assigned to groups. You can inspect groups one 
level at a time. (Items that define groups appear bold and underlined.) 

¾ To change group levels 

1. Select the REGION dimension. The item heading North America is bold and underlined 
and the status bar displays the letter ‘T’ to indicate that North America defines a totaled 
group. 

2. Click the name North America to drill down in the group. 

As you change group levels, the headings in the active dimension change. The three 
items Canada, United States, and Mexico are displayed. All three headings are bold and 
underlined to show that they too define groups. You can click on their names to drill down 
farther. 

The ‘T’ in the status bar indicates that the active cell, Canada, defines a totaled group and 
the ‘M’ indicates that it is also a member of the North America group. 

3. To display the item that defines a group, right-click an item that is a member of a group 
and choose Drill Up. 
 
Any other items that are on the same level as the defining item will also be displayed. That 
is, if you drill up on Ontario you will find not only Canada but Mexico and United States as 
well, because they are on the same level as Canada in the group hierarchy defined by 
North America. 

4.  Once you have drilled down into a group, a Drill back arrow appears beside its 
dimension heading. Click the arrow to revert to the previous group view, whether it is 
higher or lower in the hierarchy. 
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Hiding Items 
There are two quick ways to hide items. You can hide an item explicitly or implicitly. To hide 
an item explicitly, select its heading and from the Item menu, choose Hide. 

¾ To hide items implicitly 

1. Drag the COOKIE TYPE dimension into the dimension bar. 

2. Drag the pointer across the first three headings in the column dimension, Mar1994, 
Dec1993, and Nov1993. 

3. Do one of the following  

• Click the right mouse button. Choose Show. 

• From the Item menu, choose Show. 

The items you selected remain on display and the items you did not select are hidden. 

Displaying a Chart 
You can chart the items you select in the table view and change the default chart type to a 
pie, a line, or a scatter plot chart, among others. The Browser also provides options for 
styling the elements in the chart view.  

You can display a new view for a single item, step through the codes and labels, open a 
dimension view, change group levels, or search the items. 

In addition, you can replace the items in the horizontal axis and in the legend after a chart 
view has been created. This feature allows you to add more items from the same dimension, 
or switch the dimension currently on display. The Browser updates the corresponding labels 
automatically.  

¾ To display a chart view 

1. In the column dimension of the table view, select the three items: Feb1991, Apr1991, and 
Jun1991. 

2. Do one of the following: 

•  Click the Display Chart button on the toolbar. 

• From the View menu, choose Chart. 

A chart view appears. 
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Displaying a Map 
If a table has geographical information associated with it, you can view the table data in a 
map. 

You can select the colors that are used to identify which regions and cities have the highest, 
middle, and/or lowest data values on record. You can also select whether labels and/or data 
values are displayed in a map view. The Browser can display maps with or without numbers, 
region names and/or cities. 

When you select a title caption, the associated dimension is made active. You can then look 
at one item at a time by choosing the Next Item and Previous Item buttons on the toolbar. As 
you browse through items in the map view, the regions labels change to reflect the new 
information, or a new region is displayed. You can zoom in or out of a region, or you can 
search the codes or labels.  

¾ To display a map view 

1. Do one of the following: 

•  Click the Display Map button on the toolbar. 

• From the View menu, choose Map. 

A map view appears. 
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Working With Extracts 
You can create a Beyond 20/20 table from an extract file. In this exercise you will create a 
table from the sample extract SURV.IVX. 

Finding and Opening an Extract 
¾ To open an extract 

1. Do one of the following: 

•  Click the Find button on the toolbar. 

• From the File menu, choose Find. 

 The Find dialog box appears. 
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2. In the Categories area, confirm that the ‘Beyond 20/20 Demonstration Tables and Extract’ 

category is selected. 

The sample extract Surv.ivx and some table names are displayed in the Files area. They 
are assigned to the Beyond 20/20 Demonstration Tables and Extract category.  

3. In the Files area, select ‘SURV.’ The full extract title is displayed in the Title area. 

4. Click Summary for an extended description of the extract. Then click Cancel to return to 
the Find dialog box. 

5. Do one of the following: 

• Double-click on ‘SURV.’ 

• Click OK.  

The Browser displays an empty table view containing SURV.IVX.  
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Positioning Table Dimensions 
To create a multi-dimensional table, you must define what the dimensions of the table will be 
and where they will be positioned. You position dimensions by dragging and dropping source 
field tiles into the row, column, and dimension bar areas of the table view. 

¾ To position dimensions 

1. Click on the Region source field tile and hold down the left mouse button. 

2. Drag the tile into the row dimension area. 

3. Release the mouse button. 

The dimension tile appears in the table view and the Region tile is dimmed in the source 
field bar. 

Similarly, use the following information to position the remaining source field tiles into 
their corresponding dimension areas: 
 
Source field tile Dimension area 
RateZings Column dimension area 
Criteria Dimension bar 
AmountWeekly Dimension bar 

Loading Data into the New Table 
Once you have defined a table by dragging a minimum of two source field tiles into the 
dimension areas, you can load the data into the table. 

¾ To load data into the table 

1. Do one of the following: 
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•  Click the Load Data button on the toolbar. 

• From the Data menu, choose Go. 

Naming and Saving the Table 
¾ To name and save the table 

1. From the File menu, choose Save As. 

 The Save As dialog box appears. 

2. In the File Name box, enter ‘SAMPLE.IVT.’ 

3. Click Save. 

Documenting the Table 
The Summary dialog box can be accessed at any time by choosing the File command from 
the Summary cascade menu in the Edit menu. A table summary contains general information 
about the table and assists Browser users in understanding the contents of the table. 

Here is a sample of a table summary. 

 
 

¾ To document the table 

1. Using the sample table summary as a guide, enter the following information: 
Box Summary Information 
Title A description of the table. 
Category A subject area classification for the table. 
Author The author of the table. 
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Keywords Words a Browser user can enter to search for 
the table.  

Notes Any notes you wish to associate with the table 
that may be helpful to Browser users. 

Ending a Browser Session 
You can quit a Browser session at any time. 

¾ To quit the Beyond 20/20 Browser 

1. Close any open dialog boxes. 

2. From the File menu, choose Exit. 
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Finding and Opening Tables and Extracts 

Overview 
Tables and extracts can be located through the Find or the Open dialog box. The Find dialog 
box assists you in finding the table or extract you want to open by allowing you to select 
categories, search fields, and view summaries. The Open dialog box opens a table or an 
extract directly. 

Finding a Table or an Extract by Category 
You can search for tables and extracts by category using the Find dialog box. By default, the 
Find dialog box is displayed automatically when a Browser session begins. The Find dialog 
box may also be manually opened at any time during a Browser session. 

Note:  To suppress the display of the Find dialog box on start up, from the Window menu, 
choose Preferences, and clear the Display the Find dialog box on Start Up check box. 

¾ To open the Find dialog box manually 

Do one of the following: 

•  Click the Find button on the toolbar. 

• From the File menu, choose Find. 

 The Find dialog box appears. 
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      With the Find dialog box open, you can: 

• Change directories to see tables and extracts that are stored elsewhere. 

• Select one or more categories to create a list of the tables and extracts assigned to 
those categories. 

• Search for tables and extracts according to the criteria you specify. 

• View a table or an extract summary. 

       • Open a table or an extract directly from those presented. 

Changing Directories 
In some cases, not all tables and extracts are stored in one directory. If you do not see the 
table or extract you want to open, you can manually enter the correct directory, or use the 
Browse button to change directories. 

¾ To change directories 

1. From the Find dialog box, click the  (Browse) button. 

 The Browse for Folder dialog box appears. 
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2. Select the folder where you want to begin your search and click OK. 

Selecting Categories to Find Tables or Extracts 
When you prepare tables and extracts, part of the procedure is to assign a category name to 
each table and extract. The Categories box displays all of the category names that are 
assigned to the tables and extracts in the current directory. 

When you open the Find dialog box, the first category displayed is automatically selected. 
The Files box provides you with a list of all of the tables and extracts assigned to that 
category. This list contains table and extract names, their titles, and indicates whether the file 
is a table or an extract. 

¾ To select one or more categories 

1. In the Categories area, select a category name. To select more than one category, do 
one of the following: 

• Click and hold the left mouse button while dragging the pointer along the category 
names. 

• Hold the Ctrl key down and click on the category names. 

Each time you add a new category to those selected, the Browser adds the associated tables 
and extracts to the Files box. 

¾ To see a list of all the tables and extracts in the current directory 

1. From the Find dialog box, click All. 

 All of the table and extract categories are selected. Consequently, all of the tables and 
extracts in the current directory are displayed in the Files box. 

 Tip:  To clear the selection of all categories, click None. 
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Searching for Relevant Tables and Extracts 
Beyond 20/20 tables and extracts have descriptive components which tell you something 
about the contents. You can search the descriptive components to help you locate the table 
or extract you are looking for. 

¾ To search the descriptive components of a table or an extract 

1. From the Find dialog box, click Search. 

 The Search Components dialog box appears. 

 
2.  In Text to Find, enter the text you want to search for. 

 Note:  The Browser compares the text you specify to the text stored in the table or 
extract's descriptive components.  

3. In the Search Options area, select the options you want to search: 
 

Component Kind of text it contains 

Title/Description A brief description of the table or extract. 

Notes An extended description of the table or extract. 

Keywords A list of individual words or phrases that are associated with the 
table or extract. 

Dimension/Sourc
e Field Names 

The names assigned to the dimensions of a table or the source 
fields of an extract. 

Codes A symbolic value that uniquely identifies an item. A code can be an 
abbreviation or a combination of numbers and letters. 

Labels An optional word or phrase that describes an item, or the code 
which identifies that item. It can be the name of a person, place, 
object, or time value. 

4. Click OK. 

 The Browser searches the tables and extracts currently listed in the Files area. 

 If a match is found, the table and/or extract name is displayed in the Files box. In 
addition, a message showing the total number of tables and/or extracts found is 
displayed above the Files area. 

If a match is not found, the Files area is empty and the message "0 found" is displayed above 
it. In this case, you may want to clear the search result and try a different search. 
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¾ To clear the results of all searches 

1. In the Find dialog box, click Clear. 

The Find dialog box is reset. 

Opening Tables and Extracts 
You can open tables and extracts through the Find dialog box or the Open dialog box. 

¾ To open a table or an extract from the Find dialog box 

1. Do one of the following in the Find dialog box: 

• Double-click on the table or extract name. 

• Select the table or extract name and click OK. 

¾ To open a table or an extract from the Open dialog box 

1.  Do one of the following: 

•  Click the Open button on the toolbar. 

• From the File menu, choose Open. 

 The Open dialog box appears. 

2.  Select the table or extract you want to open.  If you do not see the file you want to 
open, select a different drive, directory or file type to locate the file. 

3.  Click Open. 

The table or extract is displayed in a new document window. 
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Browser Basics 

Browsing Fundamentals 

Browsing Items 
When a dimension is displayed in the dimension bar, you can use the Next Item and 
Previous Item buttons to sequentially display its items. The column and row data are updated 
each time you move to a new item. 

¾ To browse through the items associated with a dimension 

1. Select the dimension you want to browse. 

2. Do one of the following: 

•  Click the Next Item button on the toolbar to see the next item in the dimension. 

•  Click the Previous Item button on the toolbar to see the previous item in the 
dimension. 

 Your view of the data changes to show the data associated with the next or previous item 
in the active dimension. 

3. Continue clicking on the Next Item or Previous Item button until you see the item you 
want. 

Selecting Objects 
Selecting an object indicates which part of the table you want to work with; it makes the 
object active. For example, if you want to reposition a dimension, copy an item to another 
application, or sort the items in a dimension, you must first select the related object.  

In general, you click on an object to select it. 

¾ To select a dimension tile 

1. Do one of the following: 

• Click on the dimension tile you want to use. 

•  Click in the Active Dimension box. Select the name of the 
dimension you want to use. 



 38

 Notes:  When you select a dimension in the dimension bar, the dimension and the single 
item on display are both selected. 

The dimension tile is selected and highlighted in the selection color. The corresponding 
dimension is now active and its name appears in the Active Dimension box. 

¾ To select a dimension tile using the keyboard 

 Note:  To force the Browser to release control of the keyboard at any time during the 
following procedure, press Esc. 

1. Press Alt, V. 

 The View menu drops down. 

2. Do one of the following:  

• Using the down arrow key, move the cursor to the Set Active Dimension command. 
Press Enter. 

• Press A. 

 The Set Active Dimension dialog box appears.  

 
3. Do one of the following: 

• Using the up or down arrow keys, move the cursor to the name of the dimension you 
want to make active. 

• Enter the first letter of the dimension name that you want to make active. 

4. Press Enter. 

The dimension tile is selected and highlighted in the selection color. The corresponding 
dimension is now active and its name appears in the Active Dimension box.  

¾ To select a single heading 

1. Click on the row or column item heading you want to use. 

The item heading, all its associated data, and the corresponding dimension tile are 
highlighted. 

¾ To select multiple adjacent headings 

1. Position the cursor over the heading of the first item you want to use. Click and hold the 
left mouse button. 

2. Drag the pointer along the headings of the items you want to use. 

3. Release the left mouse button. 
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The item headings, all their associated data, and the corresponding dimension tile are 
highlighted. 

¾ To select multiple non-adjacent headings 

 Note:  This technique lets you select headings from the same dimension, as well as 
headings from other dimensions. 

1. Click on the heading of the first item you want to use. 

2. Hold the Ctrl key down and click on the heading of the next item you want. 

3. Repeat Step 2 until the headings of all of the items you want to select are highlighted. 

The item headings and all their associated data are highlighted. The Active Dimension 
box displays the dimension name of the item selected last. 

¾ To select all the item headings in a dimension 

1. Select the dimension you want to use. 

2.    From the Item menu, choose Select All. 

¾ To select a cell 

1. Click on the cell you want to use. A box appears around the selected cell. 

Tip:  The arrow keys can be used to move the cursor from one cell to the next in the same 
column or row. Alternatively, you can click the Next Item or Previous Item buttons on the 
toolbar to move the cursor from one cell to the next (one at a time) along a column or row. 

Hiding and Showing Items 
When a table is initially opened, all its items are shown so the view can be quite large. You 
can make the view more manageable by hiding the items you do not need.  

Note:  Hiding items does not delete them. You can return items to the view at any time. 

¾ To hide selected items from a table view 

1. Select the headings of the items you want to hide. 

2. Do one of the following: 

• Click the right mouse button and choose Hide. 

• From the Item menu, choose Hide. 

 The items you selected disappear from the view. 

Note:  To return the hidden items to the table view, select the dimension and choose Reset 
from the Dimension menu. 

¾ To show only the items you select  

1. Select the headings of the items you want to display. 

2. Do one of the following: 

• Click the right mouse button and choose Show. 

• From the Item menu, choose Show. 

The unselected items disappear from the view. 

¾ To display the reverse set of items 

1. Select the dimension that contains the hidden items you want to see. 
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2. From the Dimension menu, choose Reverse. 

All the items in the view are replaced by the ones that were hidden. 

¾ To show all the items in a dimension 

1. Select the dimension that contains the items you want to see. 

2. Do one of the following: 

• Click the right mouse button and choose Show All.  

• From the Dimension menu, choose Show All. 

All of the active dimension's items are displayed in the table view. 

Switching Dimensions 
Switching dimensions involves dragging a dimension tile from the dimension bar into the 
table, or dragging a heading from the column or row dimension areas into the dimension bar. 
When the tile or heading is dropped, the two dimensions change places. You can also switch 
column and row dimensions. 

¾ To switch dimensions 

1. Select the dimension you want to move. 

2. Do one of the following: 

• Drag and drop the tile on the row headings if you want to replace the row dimension. 

• Drag and drop the tile on the column headings if you want to replace the column 
dimension. 

• Drag and drop the tile on a dimension in the dimension bar if you want to replace one 
of the dimensions in the dimension bar. 

Nesting Dimensions 
Nesting lets you display more than one dimension along the columns or rows. It involves 
positioning a dimension tile over the border of existing headings in the column or row 
dimension. When the tile is released, new headings are added to the column or row areas. 

¾ To nest dimensions 

1.  In the dimension bar, select the dimension you want to nest. 

2.  Do one of the following: 

• Τo nest along the rows, drag and drop the dimension tile onto the outer or inner 
border of the row headings. 

• Τo nest along the columns, drag and drop the dimension tile onto the top or bottom 
of the border of the column headings. 

The dimension tile is ready to be dropped when the border of the row or column 
headings you are nesting into becomes highlighted. 

Switching and Nesting Dimensions Using the Keyboard 
The Move Dimensions command provides a keyboard alternative for moving a dimension tile. 
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¾ To move a dimension tile using the keyboard 

 Note:  To force the Browser to release control of the keyboard at any time during the 
following procedure, press Esc. 

1. Select the tile you want to move. 

2. Press Alt, V. 

 The View menu drops down. 

3. Do one of the following: 

• Using the down arrow key, move the cursor to the Move Dimensions command. 
Press Enter. 

• Press V. 

4. Press the Tab key repeatedly until the area you want to move the tile to is highlighted. 

 The Browser may highlight another tile or one of the heading areas (to switch), a border 
of the heading area (to nest), or the border of a tile in the dimension bar (to rearrange the 
order of the tiles in the dimension bar). 

5. Press Enter. 

The Browser switches or nests the dimension you selected into the area that was 
highlighted. 

Working With Items and Dimensions 

Displaying a Dimension View 
If you are not familiar with the fields that comprise a dimension, you can open a view on the 
dimension to determine its contents. When you open a dimension view, the Browser displays 
the code field and any label fields associated with that dimension. Data is not available in a 
dimension view. 

¾ To open a dimension view 

1. Select the dimension whose dimension view you want to display. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

A dimension view appears. 
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Displaying Alternate Labels 
The fields that make up a dimension of a table are created when the table is prepared. The 
Browser derives the codes or labels you see in the dimension tiles and item headings from 
this field information. 

A dimension always contains one field of codes, and may contain one or more fields of 
labels. Each code uniquely identifies an item. Labels help to define the code, or they can 
provide additional information about the item itself.  

If at least one label field is available for the active dimension, you can display the code field 
or the label field(s) in the table view. 

¾ To step through available code and label fields 

1. Select a dimension. 

2. Do one of the following: 

•   Click the Next Label button on the toolbar. 

• From the Dimension menu, choose Change Labels. 

 The displayed codes or labels are replaced with the next available field of codes or 
labels. 

As you continue changing labels, the Browser steps through all of the available fields one 
at a time. 

Examining Group Levels 
A group is an item that has an underlying hierarchical structure assigned to it. You can drill 
up and down in groups to explore the structure. 

¾ To display the members of a group (Drill down) 

1. Click on a bold, underlined item name.  

The items that are members of the group are displayed. 
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¾ To display the item that defines a group (Drill up) 

1. Select an item that is a member of a group. To determine whether an item is a member 
of a group, select it and then check the status bar. The letter M indicates that an item is a 
member of a group. 

2. From the Dimension menu, choose Drill Up (or else right-click the item and choose Drill 
Up). 

 The Browser displays the item that defines the group along with any other items that are 
on the same level of the hierarchy as the group. For example, drilling up on Ontario 
would probably display Canada, but it might also display Mexico and USA. 

Note:  To view all the items of a dimension, choose Show All from the Dimension menu. 

¾ To return to the previous group view (Drill back) 

1.  Click on the Drill Back arrow in a dimension tile.  

 The previous group view displays.  
 
Note: A Drill Back arrow only appears after you have drilled down in a group.  

Dimension Profiles 
Dimension profiles are user-defined collections of dimension items. If you work with certain 
items frequently, you can save these items as a profile and give the profile a name and 
description. You can also create a profile by importing a list of codes from an ASCII file. 
Later, you can load the profile and either select or show only those items belonging to the 
profile. 

¾ To create a dimension profile 

1. Select the items you want to use to create the dimension profile. 

2. From the Dimension menu, choose Save Profile. 

 The Save Dimension Profile dialog box appears. 

 
3. In Profile Name, enter a name for the dimension profile. 

4. In Description, enter a description for the dimension profile. 

5. Click OK. 

The items you selected are saved as a dimension profile (*.ivp). 

¾ To create an ASCII dimension profile 

1. Create a text file using Notepad or another text editor.  

2. List the codes for the items that you want to include in your dimension profile. Do not 
include anything else in the file. Put one code on each line as follows: 
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 code1 
code2 
code3 

3. Save the text file under any name you choose. It may be convenient to give it the name 
of the dimension it refers to and to save it in the root directory of your Beyond 20/20 
installation. If you use a word processor to create the file be sure to save it as plain text 
(*.txt). 

¾ To import a dimension profile 

1. From the File menu, point at Utilities and then choose Import Profile. 

 The Import Dimension Profile dialog box appears. 

 
2. Do one of the following: 

• In Import Filename, enter the name of the ASCII file you wish to import. 

• Click Browse to locate and select the ASCII file for import. 

3. In Dimension, enter the name of the dimension you want to associate the profile with. 

4. In Profile Name, enter the name you want to give the profile. 

5. In Description, enter a description of the profile. 

6. Click OK. 

The profile is now associated with the dimension, and will appear in the Load Profile dialog 
box. 

¾ To load a dimension profile 

1. From the Dimension menu, choose Load Profile. 

 The Load Profile dialog box appears. 
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2. In Profile Name/Description, select the profile you want to use. 

3. Do one of the following: 

• Click Select to select the items belonging to the profile group. 

• Click Show if you only want to display the items belonging to the profile group. 

¾ To delete a dimension profile 

 Note: Deleting a profile does not delete its items. 

1. From the Dimension menu, choose Load Profile. 

 The Load Profile dialog box appears. 

2. In Profile Name/Description, select the profile you want to delete. 

• Click Delete Profile to delete the dimension profile. 

 You are prompted to confirm the deletion. 

3. Click Yes. 

 To delete another profile, repeat from Step 2. 

Searching Items 
The Browser's dimension search capability allows you to display only the items you need. 
With this feature you can: 

• Reduce the number of items in a view. 

• Expand the number of items in a view. 

• Move the cursor to the item you specify. 

To use the search feature efficiently, it helps to be familiar with the fields of a dimension. (The 
Search command requires that you specify the name of the field you want to search.) You 
can open a dimension view to look at the fields of a dimension. 

¾ To search the code field or a label field 

Perform this kind of search when you know a word or phrase that describes the items you are 
looking for. 

1.  Select the dimension you want to search. 

2.  Do one of the following: 
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•  Click the Search button on the toolbar. 

• From the Dimension menu, choose Search. 

 The Search dialog box appears. 

 
3.  In the Field area, select Code or the name of a label field. 

4.  In Text to Find, enter the code, word, phrase, or abbreviation you want to search for. 

 Tip:  The Browser will find this text or code whether it is at the beginning, in the middle, 
or at the end of a series of characters. It is best to be as specific as possible. 

5.  In the Type of Selection area: 
Select To 
Reduce hide all items that do not match. Previously hidden items 

remain hidden. 
Expand display all hidden items that match. Previously displayed items 

remain displayed. 
Find Next search through the displayed items and move the cursor to the 

first item that matches the search. Hidden items are ignored, 
even if they match. 

6. Click OK. 

The Browser determines whether the field you selected contains the text you specified, and 
then displays the results.  

Searching Data 
Before you can search data, you must move the cursor to one of the items in the column or 
row dimension, whichever is currently inactive. The position of the cursor defines which item 
in the inactive dimension will be searched. 

Example:  In the figure below, the REGION dimension is active. The position of the cursor 
focuses the search on the data associated with all of the items in the REGION dimension, but 
only Aug1999 of the TIME PERIOD dimension. In this example, a search on the regions is 
restricted to the employee count records taken in August 1999 for all occupations. 
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Note:  In the case of nested dimensions, the position of the cursor still focuses the search on 
a single item. 

¾ To search data 

Before you can search data, you must move the cursor to one of the items in the column or 
row dimension, whichever is currently inactive. The position of the cursor defines which item 
in the inactive dimension will be searched. 

Note:  In the case of nested dimensions, the position of the cursor still focuses the search on 
a single item. 

Note:  You can only search data in a table view. (In a dimension view, only code and label 
fields are available.) 

1. Select the dimension you want to search. 

2. Do one of the following: 

•  Click the Search button on the toolbar. 

• From the Dimension menu, choose Search. 

 The Search dialog box appears. 
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3. In the Field area, select Data. 

4. In the Type of Selection area: 
Select To 
Reduce hide all items that do not match. Previously hidden items 

remain hidden. 
Expand display all hidden items that match. Previously displayed items 

remain displayed. 
Find Next search through the displayed items and move the cursor to the 

first item that matches the search. Hidden items are ignored, 
even if they match. 

5. Do one of the following: 

• In Minimum, enter a number to represent the lowest data value you want to be 
included in the search result. 

• In Maximum, enter a number to represent the highest data value you want to be 
included in the search result. 

 Tip:  To limit the search result even further, specify both a minimum and maximum value. 

6. Click OK. 

The Browser determines whether any data in the table meets your criteria, and then displays 
the results. 

¾ To search a time series dimension 

A time series search displays only those items that were recorded during a specific time 
span.  

1.  Select the time series dimension. 

2.  Do one of the following: 

•  Click the Search button on the toolbar. 

• From the Dimension menu, choose Search. 

 The Search dialog box appears. 
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3.  In the Field area, select Timeseries. 

4.  In the From area, enter the year and month that you want to search from. 

 Note:  In the From and To areas, a month is indicated by the number that refers to its 
chronological order in the calendar year. January is number 1. 

5.  In the To area, enter the year and month that you want to search to. 

6.  In the Type of Selection area: 
Select To 
Reduce hide all items that do not match. Previously hidden items 

remain hidden. 
Expand display all hidden items that match. Previously displayed items 

remain displayed. 
Find Next search through the displayed items and move the cursor to the 

first item that matches the search. Hidden items are ignored, 
even if they match. 

7. Click OK. 

 The Browser determines whether the time series field contains the time span you 
specified, and then displays the results. 

Note:  Searching time series data searches the base frequency of the data regardless of 
the time series aggregation displayed. 

Sorting and Rearranging Items 
A table can be sorted numerically by its data or alphabetically by its codes or labels. The 
items in a dimension can also be manually rearranged. 

¾ To sort items 

 Notes:  If you want to sort by data value, you must be in a table view. 

 If you want to sort a particular set of labels, ensure that they are displayed in the table 
view. 

1. Select the dimension you want to sort. 
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2. If you are sorting items that are displayed along the rows or columns of a table, select a 
cell that lies in the row or column that you want to sort. 

3. Do one of the following: 

•   Click the Sort button on the toolbar. 

• From the Dimension menu, choose Sort. 

 The Sort dialog box appears. The Field area displays the fields of the dimension. 

  
4. In the Field area, select the field you want to sort. 

 The Sort Options area displays the options for the selected field. 

5. In the Sort Options area: 
Select If you want to sort using 
Increasing data by ascending value. 
Decreasing data by descending value. 
Increasing Alphabetic the sort key 0-9, A-Z, a-z. 
Decreasing Alphabetic the sort key z-a, Z-A, 9-0. 
Increasing Numeric the sort key 0-9. All alphabetic codes or 

labels will be presented first. 
Decreasing Numeric the sort key 9-0. All alphabetic codes or 

labels will be presented last. 

6. Click OK. 

 The items in the current view are displayed in the order specified. 

Note:  To undo the most recent sort, from the Dimension menu, choose Reset. 

¾ To change the order of items 

1. Select the dimension containing the items you want to re-order. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

 The dimension view appears. 
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3. Hold the Shift key down and click on the index number of the item you want to move. 

4. Drag and drop the item to a new location. 

 The item is displayed in its new position. 

Note:  To restore the items to their original order, select the dimension and from the 
Dimension menu, choose Reset. 

Viewing Table Descriptions 
Every Beyond 20/20 table contains descriptive information about the table. This descriptive 
information, called metadata, can be found in the file summary, dimension summaries, and 
item summaries. 

The following toolbar buttons are found in all summary views: 
Button Name Function 

 
Back Shows the previous page in your history list. A history list is a list of 

the pages you have previously visited. 

 
Forward Shows the next page in your history list. 

Note:  You must have used the Back button to display a previous 
page before you can use the Forward button. 

 
Stop Stops loading the summary or web page. 

 
Refresh Loads the summary or web page again. 

 
Print Prints the summary or web page. 

 
Home Links to a predefined home page (provided you have access 

to the Internet). 

Table Summaries 
A table's summary tells you something about the contents of a table. Part of it is generated 
automatically by the Browser, and the remainder (if any) is added during the preparation of 
the table. 
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¾ To view the summary information of a table 

1. From the File menu, choose Summary. 

The Summary view appears. 

 

Dimension Summaries 
Dimension summaries are added during the preparation of a table. These summaries are 
optional, and may include information about any classification systems being used, where 
and how the source data was collected, a contact name, or reasons for any anomalies in the 
data. 

¾ To view a dimension summary 

 1.    Click the Summary icon next to the name of the dimension you want to view. 

Item Summaries 
Item summaries are added during the preparation of a table. These summaries are optional 
and typically provide an extended description of the active item. 

¾ To view an item summary 

1.    Click the Summary icon next to the name of the item whose summary you want to 
view. 

The Item Summary view appears. 
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Working with Data 

Overview 
A table's data is its most important component. The Browser allows you to: 

• Change the way numbers are displayed in a cell. 

• Display row and/or column distributions of the data. 

• Create a working copy of all or part of a table. 

• Update the data displayed in a table. 

•      Call frequently-used utilities from inside the Browser. 

•     Save only a portion of a table, or save it to a different file format. 

•      Print your data. 

Changing the Data Display 
You can customize your view of table data by changing the way numbers are displayed in the 
cells.  

You can do this by: 

• Increasing or reducing the number of decimal places. 

• Suppressing the display of zero values. 

• Changing the method used to summarize data of a time series dimension (i.e., the 
aggregation method). 

•    Changing the unit of time used to display data of a time series dimension (i.e., the display 
frequency). 

Displaying Decimals 
The Browser can display data values as integers or as decimal fractions. The level of 
accuracy needed in the data determines whether integers or fractions are stored in a table. In 
some cases (for example, when the data in a time series dimension is aggregated), the 
Browser generates and displays fractions based on the calculations it performs on stored 
integers. 

Decimal places can be set for a single item, for multiple items along one dimension, or for the 
entire table. 
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¾ To change the number of digits displayed after the decimal point 

1. Do one of the following: 

• Select one or more item headings in a dimension, in order to set the decimal places 
along those items. 

• Select a dimension tile, or a single cell in the table, to set decimal places for the 
entire table. 

2. From the View menu, point at Decimals and then choose the number of decimal places 
you want to display. 

 A check mark appears beside the selected number. 

The decimal setting remains in effect until you change it or close the table without first saving 
the view. 

The Display Zeros Option 
You can suppress the display of zero values by displaying them as empty cells. In a table 
that has many zero values this option helps to make the table more readable. 

¾ To suppress the display of zeros in a table 

1. From the Window menu, choose Preferences. 

 The Preferences dialog box appears. 

 
2. Clear the Display Zeros check box. 

3. Click OK. 

From this point on, the Browser displays blank table cells when data values are equal to zero. 

Time Series Options 
The Browser is capable of displaying data at an annual, semi-annual, quarterly, monthly, 
weekly, or daily base frequency. You have the option to aggregate the data and display it at 
any frequency that is lower than the base frequency. 

For example, an annual, semi-annual, quarterly, or monthly display frequency can be 
selected when weekly or daily data is stored in a table. An annual, semi-annual, or quarterly 
display frequency can be selected when monthly data is stored in the table. 
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Initially, when you open a table, time series data are displayed according to the actual 
frequency at which it is stored in the table. This frequency is called the base frequency. You 
can aggregate the data and display it at any display frequency that is lower than the base 
frequency and you can select how the data should be aggregated. 

¾ To select the display frequency and aggregation method 

1. From the View menu, choose Time Series. 

 The Time Series dialog box appears. 

 
2.  In the Display Frequency area, select a display frequency option button that is lower that 

the current base frequency. 

 Note:  Dimmed option buttons are unavailable. They represent frequencies that are 
higher than the base frequency. 

3.  In the Aggregation Method area: 
Select To 
Totals display the sum of all of the values associated with each of the 

underlying items for each time interval. 
Averages display the quotient obtained by dividing the sum of each of the 

underlying items by the total number of underlying items for 
each time interval. 

Minimums display the lowest data value obtained from any one of the 
underlying items for each time interval. 

Maximums display the highest data value obtained from any one of the 
underlying items for each time interval. 

First Values display the value that was recorded first (chronologically) out of 
those associated with the underlying items for each time 
interval. 

Last Values display the value that was recorded last (chronologically) out of 
those associated with the underlying items for each time 
interval. 

4. Click OK. 

The Browser performs the time series aggregations and displays the result according to the 
display frequency you selected. 

¾ To select advanced time series options 

1. From the View menu, choose Time Series. 
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 The Time Series dialog box appears. 

2. In the Advanced Options area: 
Select To 
Percent 
Change 

calculate each value as the percentage increase since the 
previous time interval. 
The calculated value is derived from two consecutive intervals of 
time. The Browser finds the difference between the two values, 
divides it by the value associated with the first interval, and 
displays the result as a percentage. 

Moving 
Averages 

calculate each value as an average that is derived from a 
number of values associated with an earlier time span. This has 
the effect of smoothing out fluctuations in the data. You can 
combine up to 16 values. 

 Note:  If you select the Moving Averages option button, in Periods, enter the number of 
items the Browser should combine to make up the new value. 

3. Click OK. 

 The time series calculations are performed and the result are displayed. 

Note:  If any of the values used to calculate percentage differences or moving averages are 
unavailable or missing, a hyphen (-) is displayed for the affected time interval. 

Defining the Fiscal Year 
The month you choose for the beginning of a fiscal year is the month the Browser will use to 
start obtaining 12-month blocks of data for time series calculations. 

¾ To select the start of the fiscal year 

1. From the View menu, choose Fiscal Year. 

 The Fiscal Year dialog box appears. 

 
2. Select the start month of the fiscal year and click OK. 

Calculating Distributions 
Distribution percentages are based on your current view of a table. You can calculate row, 
column, and/or total distributions and include them as a new dimension in a new table view. 

¾ To calculate distributions 

1. From the View menu, choose Distributions. 
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 The Distributions dialog box appears. 

 
2. In the Include Items of Dimensions area, select those dimension(s) you want to include in 

the distribution calculation. Note that the row and column dimensions are automatically 
included in the distribution calculation. The dimensions listed in Include Items of 
Dimensions are only those dimensions positioned in the dimension bar. If these 
dimensions are not selected, only the current items that appear in the dimension bar will 
be included in the distribution. 

3. In the Distribution Items area, clear any check boxes for items you want to exclude from 
the new distribution dimension. 

4. Click OK. 

 A distributions dimension with one to four items, depending on your selections in the 
Distribution Items area, is introduced into a new table view. The new window has the 
same name as the original table, prefixed with 'Distributions:'. 

 Tip:  To return to the original table view, simply close the Distributions window. 

 Notes:  If any dimensions have been nested, the sum of the data for a particular item 
across the nested dimensions is used as the base for the distribution calculation. 

 If you have hidden any items, only the items displayed in your view are used in the 
distribution calculation. 

If there are groups in your view, and any group members have been hidden, the Browser 
calculates the distribution based on the remaining group members. The group total 
appears as a dash. 

Creating a Working Copy of a Table 
Beyond 20/20 allows you to create a working copy of all or part of the current view of a table. 
This option allows you to manipulate part of a table, without affecting the original table, by 
placing the selected data into a worksheet. Any table operations may be made on the 
worksheet, such as group calculations, data imports, saving data to a table, etc. These 
operations can be made even if the original table is read-only. 

¾ To create a worksheet from a table 

1. Select the items you want to appear in the worksheet. (Or, using the Hide and Show 
commands, display only those items you want to appear in the worksheet.) 

2. From the View menu, choose Worksheet. 

 The View Worksheet dialog box appears. 
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3. In Include Items of Dimensions, select the dimension(s) you want to include in the 

worksheet. Note that the row and column dimensions are automatically included in the 
worksheet. The dimensions listed in Include Items of Dimensions are only those 
dimensions positioned in the dimension bar of the open table. If these dimensions are not 
selected, only the current items that appear in the dimension bar will be included in the 
worksheet. 

4. Click OK. 

 A new table view appears with the same title as the original table, prefixed with 
'Worksheet:'. 

 Note:  When the worksheet is created, if a timeseries dimension is placed anywhere 
other than in the column dimension of the original table, it will be converted to a normal 
dimension and timeseries operations will not be available. 

 Tip:  There is currently a limit of 8000 columns during the creation of a worksheet. If you 
require more columns, place the columns in the row dimension area before creating the 
worksheet, and then move them back to the column dimension area after the worksheet 
has been created. 

Caution:  If you close a worksheet, it will not be saved. To save a worksheet, save it as a 
table prior to closing the worksheet. When it is opened again, it will appear as a normal table. 

Importing Table Data 
Beyond 20/20 allows an existing table to be updated from another Beyond 20/20 table. For 
example, information providers can distribute monthly update tables that their customers can 
import into existing tables containing historical data.  

To import one table into another, the dimensions of both tables must be the same.  

If any new items are encountered as part of the update process they will be added into the 
existing table. 

¾ To import one table into another 

1.  Open the table you want to update. 

2.  From the File menu, choose Import. 

 The Import dialog box appears. 
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3.  Do one of the following: 

• In Input Filename, enter the name of the updating table. 

• Click the browse button to locate and select the updating table file name. 

4.  Click OK. 

Data from the updating table is loaded into the active table. 

Saving Table Data 
Data from a Beyond 20/20 table can be: 

• Saved to another Beyond 20/20 table. This is typically done when you want to work with 
a subset of a large table. 

• Exported into a different file format. 

•      Copied into another application. 

Saving Data into a New Table 
You can create your own version of an existing table, or a portion of one, by saving it as a 
new table. This is useful if you want to work with a subset of a large table or if you want to 
make changes to a read-only table. 

¾ To create a new Beyond 20/20 table from an existing one 

1.  Open a Beyond 20/20 table. 

2.  If required, limit the information in the table view by hiding, searching, or switching items.  

3.  From the File menu, choose Save As. 

 The Save As dialog box appears. 

4.  In File name, enter the name of the new table. If necessary, select a different drive or 
directory. 

5.  If you do not want to save the dimensions in the dimension bar, clear the Include Other 
Dimensions check box. 

6.  Click Save. 
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Exporting Data to a New File Format  
If you want to move information from a Beyond 20/20 table to another application, you can 
export data by saving it to another file format.  

You can choose from a number of common file formats: 
Format Description 
Comma-separated value 
(*.csv) 

Plain text file with a comma delimiter for each column 
value, and a carriage return followed by a line feed 
character to identify the end of each row. 

Text file (*.txt) Plain text file. 
WKS worksheet (*.wks) Lotus 1-2-3 Release 1A file format. 
WK1 worksheet (*.wk1) Lotus 1-2-3 Release 2 file format. 
dBASE File (*.dbf) dBase III file format. 
Aremos TSD (*.tsd) Aremos file format. 
XLS worksheet (*.xls) Microsoft Excel file format 
XML file (*.xml) eXtensible Markup Language 

¾ To export Beyond 20/20 table data 

 Notes:  Any dimensions in the dimension bar whose items you want to export must be 
nested before exporting.  

 When exporting to a dBASE file, ensure that any nesting occurs only along the rows. 

 Tip:  If you do not need to export the complete set of data from the existing table, reduce 
the number of columns and rows in the view before exporting. 

1.  Open the table you want to export. 

2.  Reduce the data in the table view by hiding items, searching for items, or switching items 
into the dimension bar.  

3.  Nest any dimensions from the dimension bar whose items you want to export. 

4.  From the File menu, choose Save As. 

 The Save As dialog box appears. 

5.  In File name, enter the name of the file you want to save. 

6.  In Save as type, select the file type that corresponds to the file format you want to create. 
If necessary, select a different drive or directory. 

7.  Click Save. 

 The data is saved in the file format you selected. 

Copying Data to Another Application 
You can transfer a selection of data to another Windows application, such as a word 
processor or a desktop publishing product, by using the Windows Clipboard. 

¾ To copy data to the Clipboard 

1. Select the cell or items that you want to copy. 

2. Do one of the following: 

• Click the right mouse button and choose Copy Cell. 

• From the Edit menu, choose Copy. 
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 The Browser copies the selected cell or items to the Windows Clipboard. 

 To paste the cells into another application, open a document in that application, make the 
necessary selections, and choose the Paste command from the Edit menu. 

Printing Data 
Table information can be printed from a table view or a dimension view. The printed copy 
resembles the view you see on the screen. 

The header at the top of a table printout includes the table's title and the dimensions from the 
Dimension bar. 

If there are columns that extend past the visible area to the right of the document window 
they are printed on separate sheets of paper. 

To create a page layout 
The Page Setup dialog box (from the File menu) enables you to create a report template (a 
model page) with which you can: 

• Control the heights and widths of various areas in your report 

• Define the fonts and text justification (alignment) used for such things as titles, labels,    
data,  and footnotes 

• Customize certain titles and labels as well as control the presence and placement of 
page numbers, missing values legend, and footnotes 

The following options are common to all three tabs of the Page Setup dialog box: 

Print Preview 
Opens the Print Preview dialog box. 

Reset 
Resets all page setup options to their initial state. Note that this is the state the settings were 
in when the program was first installed, not the most recent default settings.  

OK 
Applies changes and closes Page Setup. 

Cancel 
Cancels changes that have not yet been saved. 

Help 
Opens the online help. 

Save as Default 
Saves changes as default settings. 

¾ To set the height and width of selected report areas: 

1. Click the Page Layout tab. 

2. From the Page Area Attributes list, select the report area you want to modify. A diagram 
of the different report areas is shown at the end of this help topic. 

3. Enter the minimum and maximum size values for the selected area. The program will 
determine the best fit within the specified range of values. 
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 Note: The values you enter are expressed as a percentage of total page height or width. 
For example, assume your page height is 11 inches. You enter a minimum value of 10 
and a maximum value of 25 for Title Height. The minimum title height will be 1.1 inches 
and the maximum height will be 2.75 inches (10 percent of 11 inches and 25 percent of 
11 inches, respectively). 

4. Repeat steps 2 and 3 for each area you wish to customize. 

5. If you wish to make your new values the permanent program defaults, click the Save as 
Default button. 

 Note: If you do not click Save as Default, the program will revert to its original installation 
default values the next time you start it. 

6. If you are finished setting the formatting options for your report, click OK. 

¾ To select fonts or set the text justification for different report areas: 

1. Click the Fonts tab. 

2. From the Text to Modify list, select the report area whose font and justification 
characteristics you wish to change. A diagram of the report areas is shown at the end of 
this help topic. 

 Note: Row label (nesting) and Column label (nesting) denote higher-level dimension 
labels. Row label and Column label denote the lowest level of dimension label. In the 
example below, the Row Labels (nesting) are “Country” and “State/Province;” the Row 
Label is “City.” 
Country 
 State/Province 
  City 

3. From the Font, Font Style, Size, and Effects lists, select the various font (typeface) 
attributes you wish to apply to the item you chose in the Text to Modify list (step 2, 
above). 

 Note: Strikethrough causes a horizontal line to be drawn through each letter indicating 
the text was "struck out"—that is, marked for possible deletion. Example: strikeout text 

4. From the Justification list, select how the text is to be justified (aligned). 

 Note: Left justification aligns text along the left margin and leaves the right margin 
ragged (unaligned). Right justification aligns text along the right margin and leaves the 
left margin ragged. Center justification places each line in the center of the report area 
leaving both the left and right margins ragged. 

5. Repeat steps 2 through 4 for each report area you wish to change. 

6. If you wish to make your new values the permanent program defaults, click the Save as 
Default button. 

 Note: If you do not click Save as Default, the program will revert to its original installation 
default values the next time you start it. 

7. If you are finished setting the formatting options for your report, click OK. 

¾ To customize report titles, labels, and page numbers: 

1. Click the Content tab. 

2. To change the report title, overtype the default title shown in the Title box (maximum of 
256 characters). To reset the report title to the program-generated default, click the 
adjoining Reset button. 
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3. To add a row label title, enter an appropriate title in the Row Label Title box (maximum of 
100 characters). To remove an existing row label title, simply select and delete the text. 

4. To change the name of the data source (the person or organization who collected, 
compiled, or published the data), overtype the default shown in the Source box 
(maximum of 256 characters). To reset the data source to the program-generated 
default, click the adjoining Reset button. 

 Note: See the diagram at the end of this help topic for the location of the Title, Row Label 
Title, and Source areas on the report page. 

5. To change the secondary title (which appears directly under the main report title), select 
either Automatic or Custom. 

If you choose Automatic, you can select any combination of Include Include Other 
Dimensions, Include Row Dimensions, and Include Column Dimensions. The 
program will build a secondary title containing the requested dimension names. 

 Example: The current view is showing Province and Age Groups as row dimensions, 
Years as the column dimension, and Sex and Industry on the other dimension bar. If 
you select all three check boxes (Include Other Dimensions, Include Row 
Dimensions, and Include Column Dimensions), the secondary title will appear as: 

Sex: Males 
Industry: Management 

Occupations 
Rows: Province, Age

Columns: Years 

•If you choose Custom, enter a secondary title of your choice in the Custom box 
(maximum of 1,000 characters). 

 Note: The Automatic and Custom options are mutually exclusive; if you select one, you 
cannot select the other. 

6. To display page numbers, select the Display Page Numbers check box. Select either 
Header or Footer to tell the program where you would like page numbers placed. 

7. To display footnotes at document end, select the Display footnote legend checkbox in the 
Page Setup area. 

8. To display the missing values legend, select the Display missing values legend check 
box in the Page Setup area. 

9. If you wish to make your new values the permanent program defaults, click the Save as 
Default button. 

 Note: If you do not click Save as Default, the program will revert to its original installation 
default values the next time you start it. 

10. If you are finished setting the formatting options for your report, click OK. 
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Charts 

Overview 
As an alternative to a table view, you can display data in a graphic format. The Browser 
allows you to: 

• Display a chart view. 

• Browse through items while either dynamically updating the chart or keeping the chart 
constant. 

• Select a different type of chart. 

• Format a chart view. 

• Copy and print a chart. 

Displaying a Chart 
When you display a chart, the Browser creates a new window and displays the default chart 
in it. 

¾ To display a chart view 

1. Select the cells or items you want to display in a chart view. 

 The current arrangement of the table view and the objects you select in it determine how 
the information is reflected in the chart.  

2. Do one of the following: 

•  Click the Display Chart button on the toolbar. 

• From the View menu, choose Chart. 

A chart view opens, displaying the default chart. 
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Identifying Chart Elements 
By default, the Browser creates a two-dimensional bar chart view from the column and row 
dimensions. In addition to the data representation, a chart view can contain four other 
components: title captions, a legend, a vertical axis, and a horizontal axis. You can select, 
manipulate, and rearrange these elements. 

The following chart was created by selecting multiple columns and rows: 
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Title Captions 
One or more title captions are displayed at the top of the chart view. Initially, each caption 
contains the codes or labels associated with the dimensions and items you did not select for 
display. When you select a title caption, the associated dimension tile is highlighted in the 
table view. 

Legend 
A legend is created when you select multiple items for display. When multiple rows are 
selected, or when rows and columns are selected, row labels are displayed in the legend. 
When multiple columns are selected, column labels are displayed in the legend. 

Vertical Axis 
The units of measure on the vertical axis are scaled automatically to accommodate the 
highest and lowest data values associated with the items on display. To learn how to change 
the vertical axis, refer to Editing Axes. 

Horizontal Axis 
The labels displayed on the horizontal axis can vary according to whether you selected a cell, 
an item, or multiple items for display. The Browser displays as many labels as possible in the 
space provided. If more space is required, you can extend the horizontal axis by resizing the 
width of the window.  
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The name of the dimension associated with the horizontal axis is displayed below the 
horizontal axis. When you select the dimension name, the associated dimension tile is 
highlighted in the table view.  

ChartBrowse 
Once you have selected a dimension in a chart view, you can perform any of the following 
operations in the chart view by choosing the appropriate menu command or toolbar button. 
The Browser mirrors your activity in the table view. 

• Display the next or previous item. 

• Open a dimension view. 

• Display any available labels associated with the item. 

• Inspect a group hierarchy (if the item defines or is a member of a group). 

• Find and display the item that matches the text you specify. 

Note:  Only the code field and any available label fields can be searched in a chart view. 
Searches on the data must be done from a table view. Also, expand and reduce type 
searches are best done from a table view. 

Linking and Unlinking Dimensions 
You can hold an aspect of the data constant, or keep the current chart from changing while 
browsing the corresponding table view. To do either, you need to unlink the associated 
dimensions in the chart view. 

Note:  With the exception of the dimension in the horizontal axis (which is always held 
constant), an unlinked dimension can be linked again at any time.  

¾ To link or unlink a dimension in a chart view 

1. In the chart view, do one of the following: 

• Click the right mouse button and choose Chart Link. 

• From the View menu, choose Chart Link. 

 The Chart Link dialog box appears. The Dimensions area displays the names of all of the 
table's dimensions.  

 The check boxes that correspond to the two dimensions plotted along the vertical and 
horizontal axes of the chart are unavailable. 
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2. Do one of the following: 

• In the Dimensions area, select a check box to link that dimension. 

• In the Dimensions area, clear a check box to unlink that dimension. 

• Click Link All to link all the dimensions. 

• Click Link None to unlink all dimensions. 

3. Click OK. 

The dimensions are linked or unlinked. From this point on, the dimensions will either be 
dynamically updated in the chart view or held constant, according to your specifications. 

Switching Items in a Chart View 
After a chart view has been created, you can replace the items in the horizontal axis and the 
legend. You can also add more items from the same dimension, or switch the dimension 
currently on display. The corresponding labels are updated automatically.   

Note:  Switching dimensions in the chart view does not change the linking information. The 
dimension that was initially displayed in the horizontal axis remains unlinked. All other 
dimensions remain linked unless you explicitly unlink them. 

¾ To switch new items into a chart view 

 Notes:  A dimension tile can be switched into the legend or into the horizontal axis. 

 Any time a single item is switched into a legend, the Browser replaces the legend with a title 
caption. 

1. Do one of the following: 

•  Click the Tile button on the toolbar. 

• From the Window menu, choose Tile. 

2. In the table view, drag the dimension or items from the column or row dimension, or from 
the dimension bar, into the chart view. 

3. Do one of the following: 

• Drop the dimension or items over the data in the middle of the chart view to replace 
the dimension associated with the legend. 

• Drop the dimension or items below the horizontal axis to replace the items on display 
in the horizontal axis. 
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The items that were on display in the chart view have been replaced by the object(s) you 
dragged into the chart view. The labels and data have been updated to reflect the switch. 
If you switched a new dimension into the horizontal axis, the new title caption is 
displayed. 

Selecting Chart Options 
The chart options let you change the format of the active chart view from the default bar chart 
to another format. You can display the data as a bar chart, a line chart, or a pie chart. 

Initially, the Browser displays a two-dimensional vertical bar chart, or a two-dimensional 
vertical grouped bar chart, depending on whether you selected one or more items. You can 
select among the various chart types to change the format of the active chart view. 

¾ To change the chart type 

1. In the chart view, do one of the following: 

• Click the right mouse button and choose Chart Options. 

• From the View menu, choose Chart Options. 

 The Chart Options dialog box appears. The options that are available depend on whether 
you selected one or more items from the column and row dimensions. 

 
2. Select the chart type you want to display. 

3. Do one of the following: 

• Click Save As Default to apply the current selections to any future charts you create. 

• Click OK. 

The Browser resets the chart type and displays the results according to the options you 
selected. 

Bar Charts 
The following types of bar charts are available when you select a single row or column in the 
table view: 

 

Vertical bar chart - Creates a vertical, two-dimensional bar to 
represent each item in the horizontal axis. Every bar has the same 
color, hatch style and border assigned to it.  
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Horizontal bar chart - Creates a horizontal, two-dimensional bar to 
represent each item in the vertical axis. Every bar has the same color, 
hatch style and border assigned to it. 

 

Three-dimensional vertical bar chart - Creates a vertical, 3D bar to 
represent each item in the horizontal axis. Every bar has the same 
color, hatch style and border assigned to it. 

 

Three-dimensional horizontal bar chart - Creates a horizontal, 3D bar 
to represent each item in the vertical axis. Every bar has the same 
color, hatch style and border assigned to it. 

Grouped Bar Charts 
Note:  These options are available when you select more than one row or column in the 
table. 

 

Vertical grouped bar chart - Creates a group of vertical, two-
dimensional bars to represent a group of data points for each item in 
the horizontal axis. 

 

Horizontal grouped bar chart - Creates a group of horizontal, two-
dimensional bars to represent a group of data points for each item in 
the vertical axis. 

 

Three-dimensional vertical grouped bar chart - Creates a group of 
vertical, 3D bars to represent a group of data points for each item in 
the horizontal axis. 

 

Three-dimensional horizontal grouped bar chart - Creates a group of 
horizontal, 3D bars to represent a group of data points for each item 
in the vertical axis. 

Stacked Bar Charts 
Note:  These options are available when you select more than one item in the table. 

 

Vertical stacked bars - Creates a group of vertical, two-dimensional 
bars to represent a group of data points for each item in the horizontal 
axis.  

 

Horizontal stacked bars - Creates a group of horizontal, two-
dimensional bars to represent a group of data points for each item in 
the vertical axis. 

Each group contains one bar for each item in the legend. The same type of bar is used to 
uniquely represent each item in the legend, and the bars are positioned directly on top of 
each another. With the exception of the bars at the bottom, values for all of the other bars are 
offset by the ones plotted underneath. 

Line Charts 

 

Horizontal line - Creates a horizontal line to join all of the X-Y 
coordinates plotted for each item in the horizontal axis. There is 
one line for each item in the other dimension (whether it be 
represented by a title caption, or a legend). 

 

Vertical line - Creates a vertical line to join all of the X-Y 
coordinates plotted for each item in the vertical axis. There is 
one line for each item in the other dimension (whether it be 
represented by a title caption, or a legend). 

 

Horizontal line marker - Creates a horizontal line with markers to 
join all of the X-Y coordinates plotted for each item in the 
horizontal axis. There is one line for each item in the other 
dimension (whether it be represented by a title caption, or a 
legend).  
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Vertical line marker - Creates a vertical line with markers to join 
all of the X-Y coordinates plotted for each item in the vertical 
axis. There is one line for each item in the other dimension 
(whether it be represented by a title caption, or a legend). 

Scatter Plot Charts 

 

Horizontal scatter plot - Creates a marker at each X-Y 
coordinate plotted for each item in the horizontal axis. 

 

Vertical scatter plot - Select this option to create a marker at 
each X-Y coordinate plotted for each item in the vertical axis. 

The same type of marker is used to uniquely represent each item in the other dimension 
(whether it be represented by a title caption, or a legend). When a legend is available, you 
can choose a unique marker for each item in the legend. 

Stacked Line Chart 
Note:  This option is available when you select more than one item in the table. 

 

Stacked line - Creates a horizontal line to join all of the X-Y 
coordinates plotted for each item in the horizontal axis. 
There is one line for each item in the legend, and the area under 
each line is filled with color. The lines are stacked on top of each 
other and, with the exception of the line at the bottom, values for 
all other lines are offset by the ones plotted underneath. 

Pie Charts 
Note:  These options are available when you select one item in the table. 
 

 

Pie chart - Creates a two-dimensional pie chart with each 
section representing one item in the column or row dimension, 
whichever dimension is inactive. 

 

Three-dimensional pie chart - Creates a 3D pie chart with each 
section representing one item in the column or row dimension, 
whichever dimension is inactive. 

Other Options 
Auto Axes Adjusts the scale used to measure data values. The adjustment 

accommodates both the highest and the lowest data values so 
that all of the selected data points can be displayed at once. 

Display 
Footnote 

Displays the table title as a footnote at the bottom of the chart. 

Save As 
Default 

Accepts the current selections and applies them to any further 
charts you create. 

Displaying Chart Footnotes 
You can display the table title as a footnote at the bottom of the chart. 

¾ To display chart footnotes 

1. In the chart view, do one of the following: 

• Click the right mouse button and choose Chart Options. 
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• From the View menu, choose Chart Options. 

 The Chart Options dialog box appears. 

  
2. In the Other Options area, select the Display Footnote check box. 

3. Do one of the following: 

• Click Save As Default to make all future charts reflect the current selection. 

• Click OK. 

The chart view is displayed with a footnote. 

Styling and Formatting a Chart View 
Each chart type has its own unique set of styling options. Access styling options by double-
clicking on the object you want to format. 

Selecting Styling Options 
Because each chart type has its own set of unique styling options, a different dialog box is 
displayed for formatting bars, pie sections, lines, markers, and line markers. 

¾ To style a chart 

1.  Do one of the following: 

• Double-click on the object you want to style. 

• Double-click on the associated color in the legend (if a legend is available). 

 The dialog box with the styling options particular to the active chart type appears. 

2.  Select the options you want to use. 

3.  Click OK. 

The chart is displayed according to the options you selected. 
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Selecting Fonts 
The Browser provides you with a number of choices for assigning presentation attributes to 
the text in a chart view. You can change the point size, font, and color, or apply styles such 
as bold and italics. 

¾ To change the font of the text in a chart view 

1. Double-click on the text you want to format. 

 The Font dialog box appears. 

 
2. Select the formatting options you want to use and click OK. 

Moving a Legend 
The legend can be repositioned anywhere in the chart view. When you move it to the top or 
bottom of the view, the legend is extended across the width of the view. 

¾ To move the legend in a chart view 

1. Click on an empty part of the legend. 

2. Drag and drop the legend to the preferred location. 

Adjusting the Scale of Measurement 
You can manually edit the axes of a chart or use the automatic option to adjust the scale 
along the axes. 

Editing Axes 
You can change the settings of the axis that contains the units of measurement (usually the 
Y-axis). 

¾ To edit the axis 

 Note:  The Edit Axis option does not apply to pie charts. 

1. In a chart view, double-click on the axis containing the units of measurement. 

 The Edit Axis dialog box appears. 
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2. In Minimum, enter a lower limit for the axis. 

3. In Maximum, enter an upper limit for the axis. 

4. In Tick Space, enter the desired width between major ticks on the axis. 

5. In Minor Ticks, enter the number of minor ticks you want to appear between major ticks. 

6. Click OK. 

The chart view is displayed with the edited axis. If the coordinate for an item exceeds the 
capacity of a chart, it is either cut off at the point where the measurement ends (for bar 
charts), or it is plotted outside the confines of the chart (for line, marker, and scatter plot 
charts). 

Setting Axes Automatically 
You can automatically adjust the scale that is used to measure data values. The adjustment 
accommodates both the highest and the lowest data values so that all of the selected data 
points can be displayed at once. This feature is useful when comparing charts side-by-side. 

You can automatically set the axis through the Edit Axis dialog box or the Chart Options 
dialog box. If you have defined minor tick spaces and use the Edit Axis dialog box, the tick 
spaces remain in the new axis. 

¾ To set the axis automatically through the Edit Axis dialog box 

1. In the chart view, double-click on the axis that contains the units of measurement. 

 The Edit Axis dialog box appears. 

 
2.   Click Automatic to set the axis automatically. 

¾ To set the axis automatically through the Chart Options dialog box 

 1. In the chart view, do one of the following: 
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• Click the right mouse button and choose Chart Options. 

• From the View menu, choose Chart Options. 

 The Chart Options dialog box appears. 

 
2. In the Other Options area, select the Auto Axes check box. 

3. Do one of the following: 

• Click Save As Default to make all future charts reflect the current selection. 

• Click OK. 

Note:  When the Auto Axes check box is clear, the scale that was applied to the previous 
chart is used by default. 

Switching Axes 
You can switch the dimension displayed in the horizontal axis with the dimension displayed in 
the legend. 

¾ To switch the axes in a chart view 

1. In the chart view do one of the following: 

• Click the right mouse button and choose Switch Axes.  

• From the View menu, choose Switch Axes. 

The data is displayed in the chart view with the horizontal and legend labels 
interchanged. 

Copying a Chart 
A copy of a chart can be transferred to another Windows application, such as a word 
processor or a desktop publishing product, by using the Windows Clipboard. 

¾ To copy a chart to the Clipboard 

1. In the chart view, do one of the following: 

• Click the right mouse button and choose Copy. 
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• From the Edit menu, choose Copy. 

 The Browser copies the chart you selected to the Windows Clipboard.  

To paste the chart view into another application, open a document in that application, 
make the necessary selections, and choose Paste from the Edit menu. 

Printing a Chart 
When a chart is printed, the Browser adjusts the aspect ratio of the view automatically. This 
means that the printed chart view is as wide as the printed page, and the height of the chart 
is adjusted automatically in proportion to its width. 

¾ To print a chart 

1. In the chart view, do one of the following: 

• Click the right mouse button and choose Print. 

• From the File menu, choose Print. 
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Maps 

Overview 
As an alternative to a table view, you can present table data in a geographic context - 
provided a map file is available with the table. The Browser allows you to: 

• Display a map view. 

• Represent data values on a map. 

• Magnify and view composite regions of a map. 

• Format a map view. 

• Copy and print a map. 

Displaying a Map 
All maps provide a representation of the geographic dimension. You do not need to make a 
particular selection in the table view to display a map. Each item in a geographic dimension 
automatically corresponds to a single region or city on the map.  

Any region that corresponds to a hidden item is dimmed in the map view. 

You can only display a map if a Beyond 20/20 map file is available with the table. 

¾ To display a map 

1.  In a table view, do one of the following: 

•  Click the Display Map button on the toolbar. 

• From the View menu, choose Map. 

The map view is displayed. 

Identifying Map Elements 
The map view contains title captions, a legend, the data values associated with each region, 
and a footnote. You can select, manipulate, and rearrange these elements. 
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Title Captions 
One or more title captions are displayed at the top of the map view. The captions contain 
dimension names and labels corresponding to the intersecting items associated with the 
current position of the cursor in the table view. 

Legend 
The legend shows you which colors are currently assigned to represent the three ranges of 
data, as determined by the range definition. You can assign a different color to represent 
each range. For more information, refer to Selecting Range Colors. The legend also indicates 
the specific range of values that meet the current range definition. The legend is updated 
automatically. 

Data Values 
By default, there is one data value displayed per region. Data values are derived from the 
item that corresponds to that region and are influenced by the range definition.  

Range Colors 
The Browser uses color to represent the three ranges of data (low, middle, and high). To 
classify the data values into a range, the Browser evaluates the data according to the Range 
Definition options you select. As a result, the associated items are classified into one of the 
low range, middle range, or high range, according to the relative significance of their data.  



 80

MapBrowse 
When you click on a title caption, the associated dimension tile is highlighted in the table view 
and the map view document window remains active. 

Once you have selected a dimension in the map view, you can perform any of the following 
operations in the map view by choosing the appropriate menu command or toolbar button. 
The Browser mirrors your activity in the table view. 

• Open a dimension view. 

• Display any available labels associated with the item. 

• Inspect the hierarchy of groups. 

• Find and display the item that matches the text you specify. 

Note on searching:  Only the code field and any available label fields can be searched 
in a map view. Searches on the data must be done from the table view. Also, expand and 
reduce type searches are best done from the table view. 

Selecting Map Options 
Each region and city has a label, a data value, and a color to indicate the assigned range 
definition. 

You can select map options to determine: 

• The method used to evaluate data and assign a range definition to the corresponding 
items. 

• The colors used to represent the three data ranges. 

• Whether cities are displayed. 

• Whether labels, data values and a footnote are displayed.  

• How the range definition is applied to select which range of region labels are displayed. 

• Whether the map view is updated. 

The options you select apply only to the current map view. 

Assigning Range Definitions 
The Browser evaluates the data associated with each item according to the current setting of 
the Range Definition options. At the conclusion of the evaluation phase, each item is 
assigned a range definition (low, middle, or high). The range definition determines the color 
of a region (and/or the area around a city), and it classifies the item's label and data values 
for display purposes.  

In all cases, the region or city associated with the highest data value is highlighted in the high 
range color, and the region or city associated with the lowest data value is highlighted in the 
low range color. The color that is applied to the regions and cities with middle range values 
varies according to the range definition you selected. 

In most cases, during the evaluation phase, the Browser calculates the average of all values 
to adjust the distribution of colors for middle range values. A middle range value is assigned 
a color according to whether it is higher or lower than the average. 

¾ To assign range definitions 

1. In the map view, do one of the following: 
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• Click the right mouse button and choose Map Options. 

• From the View menu, choose Map Options. 

 The Map Options dialog box appears. 

 
2. In the Range Definition area: 
Select To 
High/ 
Low 

highlight the regions with the highest data in the High Range color and 
the regions with the lowest data in the Low Range color. All data that 
falls in between is highlighted in the Middle Range color.  

Standard 
Deviation 

highlight all regions whose data falls within one standard deviation of 
the average in the middle range color. All regions with data values 
greater than the average are highlighted with the high range color. All 
regions with data values less than the average are highlighted with the 
low range color. 

Average compare the data values to the average value (which was derived 
from all values). All values higher than the average are highlighted 
with the high range color. All values lower than the average values are 
highlighted with the low range color. Only data values that match the 
average exactly (if any exist) are highlighted with the middle range 
color. 

Linear highlight all regions with a blend of high and low range colors. The 
middle range color is not used. All regions whose data values are 
greater than the average have a higher proportion of the high range 
color. All regions whose data values are less than the average have a 
greater proportion of the low range color. 

Bilinear highlight all regions with a blend of high, middle and low range colors. 
Regions whose data values are closest to the highest data value have 
the highest proportion of the high range color. Regions whose data 
values are closest to the middle value have the highest proportion of 
the middle color. Regions whose data values are closest to the lowest 
data value have the greatest proportion of the low range color. 
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3. Click OK. 

The Browser calculates the average of all values and adjusts the distribution of colors for 
the range values according to the definition option you selected.  

Selecting Range Colors 
You can select a color to represent the highest value (high range color), the lowest value (low 
range color), and all of the data in between (middle range color). The Browser adjusts the 
distribution of these colors automatically according to the evaluation method you select in the 
Range Definition area.  

¾ To select range colors 

1. In the map view, do one of the following: 

• Click the right mouse button and choose Map Options. 

• From the View menu, choose Map Options. 

 The Map Options dialog box appears. 

  
2. In the Range Colors area, select the colors you want to use to define the low, middle and 

high ranges.  

3. Click OK. 

The distribution of colors is adjusted according to your selections. 

Displaying Region Labels 
¾ To display region labels 

1. Open the map view you want to change. 

2. Do one of the following: 

• Click the right mouse button and choose Map Options. 

• From the View menu, choose Map Options. 
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 The Map Options dialog box appears. 

 
3. In the Contents area: 
Select To 
Display Region 
Names 

display labels associated with the regions on the map. 
Note:  Select the Show Cities check box to display labels 
associated with cities, provided the information is available. 

Display Data 
Values 

display data values associated with the regions on the map. 
Note:  Select the Show Cities check box to display data values 
associated with cities, provided the information is available. 

Display 
Footnote 

display the table title as a footnote. 

 Note:  When you select an option in the Contents area, you must also select one or 
more options in the Display area to qualify it. 

4. In the Display area: 
Select To 
Show Low 
Range Labels 

display the label or data value associated with every region that 
falls into the low range definition. 

Show Middle 
Range Labels 

display the label or data value associated with every region that 
falls into the middle range definition. 

Show High 
Range Labels 

display the label or data value associated with every region that 
falls into the high range definition. 

Hide Zero 
Labels 

hide labels displaying a zero value. 

 Note: The Browser does not let you make any selections in the Display area until you 
make a selection in the Contents area. 

5. Click OK. 

The map view displays the selections you specified. 
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Displaying Cities 
Each city has a label (city name) and a data value. If you want to see the labels and/or data 
values associated with cities, you must select the corresponding options from the Contents 
and Display areas in the Map Options dialog box. The selections you make for cities in the 
Region Labels and in the Range Colors areas affect the way colors, labels, and data values 
for all other items are displayed. For more information, refer to Displaying Region Labels. 

Note:  The Show Cities option is only effective when cities are associated with the table. 

¾ To display cities 

1. In the map view, do one of the following: 

• Click the right mouse button and choose Map Options. 

• From the View menu, choose Map Options. 

 The Map Options dialog box appears. 

 
2. In the Cities area, select the Show Cities check box. 

3. Click OK. 

The map view displays the labels and/or data values for any cities. 

Linking and Unlinking a Map 
When you link a map to a table, the map view is automatically updated as you browse the 
table. For example - from the table view, if you move to the next item of a dimension in the 
dimension bar, the appropriate title caption and display of the map will reflect the new item. 

¾ To link or unlink a map 

1. In the map view, do one of the following: 

• Click the right mouse button and choose Map Options. 

• From the View menu, choose Map Options. 
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2. Do one of the following: 

• Select the Link Map to Data check box to link the map view to the table view. 

• Clear the Link Map to Data check box to unlink the map view from the table view. 

3. Click OK. 

Depending on your selection, the map view is either held constant or is updated as you 
browse through items in the table. 

Changing the Layout of a Map 

Zooming Into and Out Of a Region 
The items in a geographic dimension are typically structured into groups - smaller regions or 
cities are grouped to comprise a larger region. 

Initially, the smaller areas are not visible in the map view; only the larger areas are displayed. 
However, you can zoom into a region that is made up of smaller areas. Then you can see the 
data associated with the smaller regions.  

When you are looking at a number of smaller regions, you can zoom out to view the larger 
region. 

¾ To zoom into a region 

1. In a map view, select a region that contains smaller regions. To determine whether the 
active region contains constituent regions, select the region and check the status bar. If 
the letter T, P, or C is displayed, the region contains a total, protected, or computed 
group. 

2. Do one of the following: 

• Double-click on the region that interests you. 

• Click the right mouse button and choose Zoom In. 



 86

• From the View menu, choose Zoom In. 

The Browser displays the constituent regions that comprise the active region. 

¾ To zoom out of a region 

1. Select any region that is part of a larger region. To determine whether the active region is 
part of a larger region, select the region and check the status bar. If the letter M is 
displayed, the region is part of a larger region.  

2. Do one of the following: 

• Double-click on any white space surrounding the map. 

• Click the right mouse button and choose Zoom out. 

• From the View menu, choose Zoom out. 

The Browser displays the larger region and all of the surrounding areas. 

Magnifying Part of a Map View 
If you have zoomed into a region as much as possible and you still want to get a closer look, 
you can magnify a portion of the map view.  

¾ To magnify part of a map view 

1. Hold the Shift key down and click on the part of the map you want to magnify. 

2. Drag the cross-hair pointer across the part of the map you want to magnify. 

3. Release the mouse button and the Shift key. 

 The Browser magnifies the area you selected. 

Tip:  To quickly magnify a region so that it fills the display area, hold the Shift key down 
and click on the region that interests you. 

¾ To restore a magnified map view to normal size 

1.  Do one of the following: 

• Click the right mouse button and choose Restore. 

• From the View menu, choose Restore. 

The map is restored to its original view. 

Moving a Legend 
You can move the legend anywhere in the map view. 

¾ To move a legend 

1. Click on any part of the legend that is not being used to display text or the color scheme. 

2. Drag and drop the legend in the preferred location. 

Moving Region Labels 
You can move region labels anywhere inside the border of the map view, except on top of the 
legend. 
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¾ To move a region label 

1. Position the mouse pointer over the region label you want to move. 

2.   Hold the Shift key down, and drag and drop the region label in a new position. 

Copying a Map 
A copy of a map can be transferred to another Windows application, such as a word 
processor or a desktop publishing product, by using the Windows Clipboard. 

¾ To copy a map to the Clipboard 

1. Click on the map you want to copy. 

2. Do one of the following: 

• Click the right mouse button and choose Copy. 

• From the Edit menu, choose Copy. 

 The Browser copies the map you selected to the Windows Clipboard.  

To paste the map view into another application, open a document in that application, 
make the necessary selections, and choose Paste from the Edit menu. 

Printing a Map 
When a map is printed, the Browser adjusts the aspect ratio of the view automatically. This 
means that the printed map view is as wide as the printed page, and the height of the map is 
adjusted automatically in proportion to its width. 

¾ To print a map 

1. Click on the map you want to print. 

2. Do one of the following: 

• Click the right mouse button and choose Print. 

• From the File menu, choose Print. 

 The Print dialog box appears. 

3. Select the print options you require. 
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Extracts 

Overview 
When working with extracts, you can: 

• Locate an extract, and browse its contents. 

• Customize source fields prior to creating a table by: applying record constraints, 
redistributing items, redefining ranges, and applying arithmetic operations. 

• Fill a table with values that are sums or averages of a numeric source field, or values that 
are weighted. 

• Create and save a table. 

•      Export an extract to a new file format. 

Finding and Opening Extracts 
To create your own table, you must first locate and open an extract. You can find and open 
an extract using the Find command from the File menu.  

Viewing an Extract Summary 
An extract summary contains textual information which describes the contents of the extract. 
Some of this information is provided by the extract creator and the rest is generated 
automatically by Beyond 20/20. 

¾ To browse an extract summary 

1. From the Data menu, choose Extract Summary. 

An Extract Summary view appears. 
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Finding Source Fields 
Source fields are the components of an extract from which you create a table. When source 
fields are positioned into an empty table view, they become dimensions. 

From within an extract you can view the contents of a source field (i.e., its dimension view) by 
double-clicking on the source field you want to explore. 

¾ To open the Find Source Field dialog box 

1. From the Data menu, choose Find Source Field. 

 The Find Source Field dialog box appears. 
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 With the Find Source Field dialog box open you can: 

• Select one or more categories to create a list of source fields assigned to those 
categories. 

• Search for source fields according to criteria you specify. 

• View a source field summary. 

• Find a source field. 

Selecting Categories to Find Source Fields 
When you open the Find Source Field dialog box, the Categories area displays all of the 
category names that are assigned to the source fields. The Fields/Type area provides you 
with a list of all of the source fields assigned to that category. 

¾ To select one or more source field categories 

1. In the Categories area, select a category name. 

2. To select more than one category, do one of the following: 

• Click and hold the left mouse button while dragging the pointer along the category 
names. 

• Hold the Ctrl key down and click on the category names. 

Each time you add a new category to those selected, the Browser adds the associated 
source fields to the Fields/Type area. 

Searching for Relevant Source Fields 
Each source field has descriptive components that provide information about the contents of 
the source field. 
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The descriptive components correspond to several fields of text. You can search the text in 
these fields to find a source field that contains the information you are looking for. 

¾ To search a source field's descriptive components 

1. From the Find Source Field dialog box, select one or more categories you want to 
search.  

2. Click Search. 

 
 The Find Source Field Search dialog box appears. 

3. In Text to Find, enter the text you want to search for. 

4. In the Search Options area, select the fields you want to search. 
Component The kind of text it contains 
Title/Description A brief description of the source field. 
Notes An extended description of the source field. 
Keywords A list of individual words or phrases that relate to the contents 

of the source field. 
Dimension/Source 
Field Names 

The name of the source field. 

Codes The codes associated with the source field. A code is a 
symbolic value that uniquely identifies an item. 

Labels The labels associated with the source field. A label is a word 
or phrase that describes an item, or the code which identifies 
that item. 

5.  Click OK. 

 The Browser compares the text you specified to the text stored in the source field's 
descriptive components. Any matching source fields are displayed in the Fields/Type 
area, and the total number found is displayed above it. 

If a match is not found, the Field/Type area is empty and the message '0 found' is 
displayed above it. In that case, you might want to clear the result in the Find Source 
Field dialog box and try a different search. 

Viewing a Source Field Summary 
¾ To view a source field summary 

1. Select a source field in the Fields/Type area of the Find Source Field dialog box. 
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2.  Click Summary. 

 The Source Field Summary dialog box appears. 

3.  Click OK to return to the Find Source Field dialog box. 

Tip:  You can view a source field summary at any time. To do this, select the source field 
tile and from the Data menu, choose Source Field Summary. 

Locating a Source Field  
¾ To locate a source field 

1. Do one of the following in the Find Source Field dialog box: 

• In the Fields/Type area, double-click on the source field you want to locate. 

• In the Fields/Type area, select the source field you want to find and then click OK. 

The source field tile is highlighted on the source field bar. 

Creating Custom Source Fields 
You can create your own source fields based on the source fields provided in an extract. 
Once created, these new source fields become part of the extract and remain in the extract 
until you delete them. You can use these custom source fields to create custom dimensions 
in tables of your own design. Each of the following operations creates a new source field. 

Recoding Source Fields 
Recoding a source field allows you to create a new source field which contains a 
redistribution of the items from the original source field. For example, if the original source 
field contains items for small geographic regions (e.g., states or provinces), you can recode 
the items to create a new source field for larger geographic regions (e.g., the Midwest or 
Atlantic region). 

Note:  When recoding a source field, all codes in the original source field must be assigned 
to the recoded source field. 

¾ To recode a source field 

1. Do one of the following: 

• Click the right mouse button on the source field tile you want to recode. Choose 
Define Recode. 

• From the Data menu, choose Define Recode. 

 The Define Recode dialog box appears and the active source field displays in the Source 
Field Name area. 

 Note:  If the Source Field Name area does not contain the field you want to recode, 
select the appropriate field from the Source Field Name drop-down list. 
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2. In the New Source Field Name area, enter a name for the new source field, or use the 

default name displayed. 

 The existing codes for the source field are displayed in the Available Codes area. 

3. In New Code, enter a name for the new item. 

4. Define or modify the codes that will make up the new item. 
To Select  
Add members  the codes in the Available Codes area. Click Add. 
Remove members  the codes in the Members area. Click Remove. 

 Tip:  To select non-consecutive codes, hold the Ctrl key down and click on each code. 
To select consecutive items, click on the first code, hold the Shift key down, and click on 
the last code. 

5. Repeat from Step 3 for each item in the new source field. 

6. If codes remain in the Available Codes area that are not to be recoded, select them and 
click Use As Is. 

7. When all available codes have been reassigned, the OK button becomes available. Click 
OK. You are prompted to confirm the creation of a new field. 

8. Click OK. 

A new source field tile appears in the source field bar. 

Creating New Bands for Numeric Source Fields 
When an extract is created, default numeric bands are assigned to all numeric source fields 
that do not have an associated dimension definition file. You can modify these bands with the 
Define Bands command.  

For example, if an original age source field contains 5-year age bands it can be rebanded to 
contain 10-year bands. 
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¾ To create bands of equal size 

1. Do one of the following: 

• Click the right mouse button on the numeric source field you want to reband. Choose 
Define Bands. 

• From the Data menu, choose Define Bands. 

 The Define Bands dialog box appears. 

 Notes:  If Source Field Name does not contain the field you want to reband, select the 
appropriate field from the Source Field Name drop-down list. 

 The Code/Description area displays one code containing the true minimum and 
maximum values of the source field. 

 
2. In New Source Field Name, enter a name for the new source field, or use the default 

name displayed. 

3. If you want to create custom bands or modify existing bands, proceed to To create 
custom bands (below). 

4. In Start, enter a value that is equal to or less than the lowest value in the 
Code/Description area. 

5. In Increment, enter a value to be used as the constant width for all bands. 

 Note:  When you enter a value in Start or Increment, the OK button dims to prevent you 
from creating a new source field before the bands are applied. 

6. Click Apply. 

 The Browser assigns the bands necessary to contain all values in the source field and 
displays them in the Code/Description area. 

7. If you want to modify these bands, proceed to To create custom bands, below. 
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8. Click OK. 

 You are prompted to confirm the creation of a new field. 

9. Click OK. 

A new source field tile appears in the source field bar. 

¾ To create custom bands 

1. From the Define Bands dialog box, click Advanced. 

 The Define Band area is displayed at the bottom of the dialog box. 

2. In the Define Band area, enter the following options: 
In  Type  
New Code  a character combination representing the new code. 
Minimum  the value that will be the lower threshold of the band. 
Maximum  the value that will be the upper threshold of the band. 

3. Select the following check boxes: 
Select If you want the Browser to 
Renumber sequentially renumber the numeric codes. 
Inclusive include the value in the minimum or maximum areas in 

the band. If you want all but the value to be included, 
clear the Inclusive check box. 

 Note:  In the display of a band, an inclusive endpoint is denoted by a square bracket and 
an exclusive endpoint is denoted by a round bracket. 

4. In the Create New Field as area, select the option button corresponding to the field type 
for the new source field. Select numeric if you subsequently want to reband or perform 
operations on the new field. 

5. Click OK. 

 You are prompted to confirm the creation of a new field. 

6. Click OK. 

A new field tile appears in the source field bar. 

Deriving New Source Fields Using Arithmetic Operations 
You can derive new source fields by combining arithmetic operations and existing source 
fields in formulas. The formulas can include 'if,' 'then,' 'else,' and 'endif' expressions to allow 
for conditional constructs.  

The result of a formula is a numeric field. 

Follow these rules when designing formulas: 

• The following arithmetic operators may be used:  
+(add), -(subtract), *(multiply), /(divide), and ^(raise to the power). 

• The following relational operators may be used:  
<(less than), <=(less than or equal to), =(equal to), >=(greater than or equal to),  
>(greater than), and <>(not equal to). 

• In an expression, ^ is evaluated before * and / which are in turn evaluated before + and -. 
Otherwise, evaluation proceeds in a left to right order. 

• Round brackets ( ) are used to alter the order of execution. 



 96

• If, then, else, and endif constructs are used to create more complex formulae. All four 
words (if, then, else, endif) must be included in your constructs. 

• Square brackets must be used around source field names containing special characters 
(e.g., blanks or _ ). For example, [Field One]. 

• You may use coded fields in the condition of an if, then, else construct, but you must use 
quotes around the code (e.g., Sex ="1"). 

Formula examples: 
Formula New field contains 
Salary*1.1 Salary multiplied by 1.1 
(Age+20)/2 (Age plus 20) divided by 2 
if Age >40 then Salary*1.05 
else Salary*1.15 endif 

If Age is greater than 40, then Salary is 
multiplied by 1.05; if Age is less than or 
equal to 40, Salary is multiplied by 1.15. 

if Sex = "1" then 0 else 
Salary*1.1 endif 

If Sex = code 1, zero; otherwise Salary is 
multiplied by 1.1 

¾ To derive a new source field 

1. From the Data menu, choose Define Derived Field. 

 The Define Derived Field dialog box appears. 

 
2. In New Field Name, enter a name for the new field. 

3. In Formula, enter an expression to describe how the new field is to be calculated. 

 Tip:  To include an existing source field in your formula, double-click on the appropriate 
field name in Available Fields, or else highlight the field name you want to include and 
choose Insert. 

4. Click OK. 

 You are prompted to confirm the creation of a new field. 

5. Click OK. 

A new source field tile appears in the source field bar. 
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Creating a Table from an Extract 

Planning a Table 
The following points outline some of the things you should consider before creating a table: 

• Determine what purpose the table will serve and what questions it should answer. This 
will help you decide what the dimensions should be and if you want to create any 
customized source fields. 

• Decide on the order of the dimensions. The order you set determines the default view 
when a table is opened. 

• Determine if there is textual information available that describes the table and/or the 
dimensions and items. 

Positioning Tiles for Dimensions 
To position source fields as dimensions, drag and drop the source field tiles into the row, 
column, and dimension bar areas of the table view. 

Notes:  A table can have to up ten dimensions. Place the first dimension in the row 
dimension area, the second in the column dimension area, and the rest on the dimension 
bar. Dimensions can be rearranged any time before you click the Go button. 

If there is a date field in your source file, you should place it in the column dimension area to 
take advantage of Beyond 20/20's time series features. 

¾ To position tiles 

1. Click on the source field tile you want to appear in the table and hold down the left mouse 
button. 

2. Drag the tile into a dimension area. 

3. Release the mouse button. 

 The dimension tile appears in the table view and the corresponding source field tile is 
dimmed in the source field bar. 

4. Repeat for each source field that you want to appear in the table. 

Filling a Table With Numeric Source Field Values 
If you prefer, you can fill a table with values that are sums or averages of numeric source 
fields, instead of counts or weighted counts. 

¾ To fill a table with numeric source field values 

1. Drag and drop a numeric source field tile into the cell area of the table view. 

 The Edit Unit Item dialog box appears. The name of the source field tile you dragged into 
the cell area is displayed as Based on Field. 
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2. In Item Name, confirm or change the name you want to give the new item. 

3. In Calculated As, select the statistical method you want to apply. 

 An asterisk appears in the source field tile to indicate that the Browser has created a new 
item in the "Units" dimension based on this source field. 

Tip:  You can use the same source field more than once to calculate different units for that 
field. Or, you can fill the table with several source fields by dragging them individually and 
dropping them into the table. An individual item is created in the Units dimension for each 
combination of source field and statistical method you include. 

Setting Record Constraints 
If you want to limit the source records that are loaded into a table, or create a new extract 
whose underlying data has been constrained, you can apply record constraints. 

The Record Constraints view allows you to: 

• Impose one or more constraints on all records during the creation of a table. 

• Impose one or more constraints before creating a new extract. 

¾ To set record constraints 

1. From the Data menu, choose Record Constraints. 

 The Record Constraints view appears. Each column potentially represents a constraint. 
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2. Select the source field you want to use to create a constraint and drag it into the first 

empty column in the view. If a non-numeric field does not have a dimension definition file 
associated with it you are prompted to confirm the creation of one. 

 The source field name appears in the Field row. 

 Notes:  If the source field is numeric, the lowest and highest data values appear in 
square brackets in the Criteria row (e.g., [18, 89]). 

 If the field is coded, the codes related to the source field appear in quotation marks 
preceded by an equal sign in the Criteria row (e.g., ="4"). 

3. Double-click on the text in the Criteria row. 

• If the text you select is numeric, the Numeric Constraint dialog box appears. 
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• If the text you select is coded, the Constraint Field dialog box appears. 

 
 

In the Select 
Numeric 
Constraint dialog 
box 

a range or comparison constraint. 
Notes:  If you select a range constraint, enter the minimum and 
maximum values to be included in the constraint. Select 
Inclusive to indicate that the range used to constrain the source 
field is inclusive of the minimum and maximum values. 
If you select a comparison constraint, choose a comparison 
operator and, in the Value box, enter the value you want to use 
as the constraint. 

Constraint Field 
dialog box 

the codes you want to include in the constraint. 
Tip:  To select non-consecutive codes, hold the Ctrl key down 
and click on each code. To select consecutive codes, click on 
the first code, hold the Shift key down, and click on the last 
code. 

4. Click OK. 

 The Record Constraints view appears. 

5. Repeat from Step 2 for each source field you want to impose constraints on. 

 Tip:  If you make a mistake, simply drag the source field back to the source field bar. 

 Note:  As you drag and drop the source fields into the columns, a single vertical line 
separates the columns that are filled. This indicates an And condition, where the Browser 
will search for records that match all of the constraints in each of the columns. If you want 
to indicate an Or condition, select a column and click Or. A separation and the word Or 
appear to the right of the selected column indicating that the Browser will search for 
records that match the constraints in either column (or group of columns). 

 To change the Or condition back to an And condition, click And. 
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6. To constrain the data that will be loaded into the table, close the view. 

 The constraints are applied and are detailed in the notes section of the table summary 
when the table is created. 

 Note:  Constraints may be modified at any time before the table is created. 

7. If an extract is open and you want to create a new extract that contains records according 
to the constraints specified, choose Save Extract As from the File menu. 

 The Save As dialog box appears. 

8. Save the new extract. 

An extract containing only the data that satisfies the constraints is created and an 
associated set of dimension definition files are saved. The new extract is independent of 
the original extract. 

Applying a Weighting Factor to the Data 
If you are working with an extract that represents data collected from a survey, there will 
probably be at least one field that contains weights. These weights are used to generate 
population-based tables from sample survey data.  

If an extract is pre-weighted, one of the weight fields is dimmed in the Source Field bar. 
Tables built from a pre-weighted extract will automatically contain weighted values. 

You can use any numeric source field as a weighting factor during table creation. 

¾ To set a weight field 

1. From the Data menu, choose Set Weight Field. 

 The Set Weight Field dialog box appears. Only numeric fields from the source file are 
displayed. 
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2. Select the Use Weight Field check box. 

3. Select the field that you want to use as the weight field and click OK. 
 
The source field selected to weight the data appears dimmed in the source field bar, 
indicating that it is unavailable for use as a dimension. 

Note:  When a weighted table is created, the notes section of the table summary 
indicates which field was used as the weight field. 

Setting Table Options 
With the Table Options command, you can control whether a table supports missing values 
and whether or not users can modify the table. 

¾ To set table options 

1. From the Data menu, choose Table Options. 

 The Table Options dialog box appears. 
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2.   If you want to enable missing values, in the Missing Values Support area: 
 

Select If you want the Builder to  
Missing Values Not 
Enabled 

display zeros in the cells of the table to indicate that 
no source data for that cell was found. 

Table Initialized to 
Missing Values 

initialize all cells of the table to dashes before the 
source file is processed. 

 Once a table is created, you cannot change the missing values support. To determine if 
the missing values option was enabled when the table was built, check the table's 
summary statistics. 

3. To prevent users from modifying the table, check Lock Table after Build. (For this option 
to work, you must save the table in IVT format before you build it.) The table will be 
Read-Only. 

4. Click OK. 

Loading Data Into the Table 
Once you have defined the table (by positioning a minimum of two source field tiles as 
dimensions and, optionally, filling it with numeric source values), you are ready to create the 
table. 

Note:  Since tables created from extracts are processed in memory, the size of the table is 
limited by the amount of available memory. 

¾ To create the table 

1. Do one of the following: 

•  Click the Load Data button on the toolbar. 
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• From the Data menu, choose Go. 

 The table is created and the table view is displayed. 

 Note:  The extract file remains open, so you can build more tables if you wish. 

Saving the Table 
¾ To name and save the table 

1. From the File menu, choose Save As. 

 The Save As dialog box appears. 

2. In File name, enter the name of the table. If necessary, select a different drive or 
directory. 

3. In Save as type, select Data Table (*.ivt). 

4. Click Save. 

Utilities 

Sorting Source Field Tiles  
Source field tiles are listed in the source field bar. Each of the tiles represents a source field 
which can be used as a dimension or a unit of measurement during the creation of a table.  

Source field tiles can be listed either alphabetically, or in the order in which they were 
created. 

¾ To sort source field tiles 

1. From the Window menu, choose Preferences. 

 The Preferences dialog box appears. 

 
2. Do one of the following: 

• Τo display the source field tiles in alphabetical order, select the check box for Sort 
Source Field Tiles Alphabetically. 
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• Τo display the source field tiles in the order in which they were created, clear the 
check box for Sort Source Field Tiles Alphabetically. 

3. Click OK. 

Deleting a Source Field 
You can delete source fields that you no longer require. 

Caution:  Once a source field is deleted, you cannot get it back. 

¾ To delete a source field from an extract 

1. Select the source field you want to delete. 

2. Do one of the following: 

• Click the right mouse button. Choose Delete Source Field  

• From the Data menu, choose Delete Source Field. 
 
The Browser asks you to confirm that the field you have selected is really the one 
you want to delete. 

3. Click OK. 

The source field is permanently deleted. 

Recreating an Extract 
If you receive a message when trying to open an extract indicating that the Browser cannot 
find a file associated with the extract, you must recreate the extract. 

You can recreate an extract either from the extract file or from one of its constituent 
dimension definition files. 

¾ To recreate an extract 

1. From the File menu, point at Utilities and then choose Recreate Extract. 

 The Recreate Extract dialog box appears. 

2. In File name, enter or select the name of the extract file, or one of its constituent 
dimension definition files, that you want to recreate. If you do not see the file you want to 
recreate, select a different drive or directory to locate the file. 

3. Click Open. 

Tip:  If you have the extract open when you recreate it, you must close and reopen it to 
get an updated copy. 

Exporting an Extract to a New File Format 
The Browser allows you to export a Beyond 20/20 extract to another file format. This 
facilitates the transfer of source field data into other software packages. 

If you have applied any constraints, the Browser allows you to save only those records that 
match the constraints. 

You can choose from the following file formats: 
Format Description 
dBASE File (*.dbf) dBASE III file format. 
SAS File (*.sas) SAS file format. 
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SPSS File (*.sps) SPSS file format. 

¾ To export an extract to a new file 

1.  Open the extract you want to save as a new file. 

2.  From the File menu, choose Save Extract As. 

3.  In File name, enter the new file name. If necessary, select a different drive or directory. 

4.  Click Save. 

 The Export Extract dialog box appears. 

 
5.  In Available Fields, select the fields you want to export. 

6.  If you have applied any constraints and want to save only those records that match the 
constraints, select the check box for Apply current constraints. 

7.  Click OK. 

Note:  When exporting an extract to a SAS or SPSS file format, two files are created. 
The text file (.txt) contains the data and the SAS (.sas) or SPSS (.sps) file contains the 
file layout and description information. 
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Customizing Tables and Extracts 

Overview 
After creating or browsing a table, you may want to customize it to better suit your needs. 
The following Browser activities provide you with the tools to do this: 

• Create groups of items to establish a hierarchy or create totals. 

• Add fields to a dimension and either manually add or import labels. 

• Save one or more views of the table. 

• Document a table by adding table, dimension and item summaries. 

Groups 
A group is an item that has an underlying hierarchy associated with it. A total group is one 
whose data values have been created by summing those members of the group. A protected 
group defines a hierarchy; however its data values are independent of the items in the group. 
A computed group is calculated by applying formulas to selected items. 

When the cursor is on a cell that either defines a group or is a member of a group, the status 
bar displays a T, P, or C indicating a total, protected, or computed group, and an M for a 
member of a group. The names of items that define groups appear bold and underlined. 
Groups can be members of other groups in a multi-level hierarchy. 

By default, groups appear at the end of a dimension. If you want to specify where the group 
is to be placed, you can add an item for the group. 

Adding and Deleting Items 
¾ To add an item 

1. Select the dimension that you want to add an item to. 

2. Position the cursor on the item that is to be before or after the new item. 

3. From the Item menu, choose Insert. 

 The Insert Item dialog box appears. 
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4. In Item Code, enter the code for the new item. 

5. In the Where to Insert area, select the option that indicates where the new item should be 
placed. 

6. Click OK. 

The new item displays in the current view. 

¾ To delete an item 

 Caution:  Once an item is deleted, you cannot retrieve it. 

1. Select the item to be deleted. 

2. From the Item menu, choose Delete Item. 

 You are prompted to confirm the deletion. 

3. Click OK. 

Note:  If you delete an item that belongs to a group, the values of the group total do not 
change until you rerun the Calculate command.  

Defining a Group 
Note:  You cannot define groups in a time series dimension. 

¾ To define a total group or a protected group 

1. Select the items in a dimension that you want to become members of the group.  
 
Tip:  If you want to create a group that is made up of all the items in a dimension, make 
that dimension active and leave all the items unselected. 

2. From the Item menu, choose Define Group. 

 The Define Group dialog box appears. 
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3. In Group Code, enter a unique name or item code to represent the group. 

4. In the Group Type area: 
Select To 
Total sum the data values of the members of the group. 
Protected define a group hierarchy while leaving the data as is (i.e., the 

data will not be affected by the Calculate command). 

5. Click OK. 

 If you are defining a total group, you are prompted to proceed with the calculation of the 
groups. 

Click To 
Yes calculate all groups. 
No calculate groups at a later time. 

The new group code appears in the current view. The status bar displays a T or P to 
indicate the group type. 

¾ To define a computed group 

Notes:  You cannot define groups in a time series dimension. 

If two computed groups intersect, the result is 0. 

1. From the Item menu, choose Define Group. 

 The Define Group dialog box appears. 

2. In Group Code, enter a unique name or item code to represent the group. 

3. Select the Computed option button. 

4. In the Formula area, enter an expression to describe how the new group is to be 
calculated. 

 Tip:  To include existing items in your formula, double-click the appropriate item name in 

the Items box or highlight the item name you want to include and click  . 

 Observe the following rules when constructing your formula: 
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• The following arithmetic operators may be used: 
+(add), -(subtract), *(multiply), /(divide), and ^(raise to the power). 

• The following relational operators may be used:  
<(less than), <=(less than or equal to), =(equal to), >=(greater than or equal to), >(greater 
than), and <>(not equal to). 

• In an expression, ^ is evaluated before * and / which are in turn evaluated before + and -. 
Otherwise, evaluation proceeds in a left to right order. 

• Round brackets ( ) are used to alter the order of execution. 

• If, then, else, and endif constructs are used to create more complex formulae. All four 
words (if, then, else, endif) must be included in your constructs. 

• Square brackets must be used around item names containing special characters (e.g., 
blanks or _ ). For example, [Field One]. 

5. Click OK. 

 You are prompted to proceed with the calculation of the groups. 
Click To 
Yes calculate all groups. 
No calculate groups at a later time. 

The new group code appears in the current view. The status bar displays a C to indicate the 
group type. 

Selecting the Members of a Group 
Items that are members of a group are represented by the letter M in the status bar. Select 
Group is used to confirm a group's members or to quickly select the items that belong to a 
group. 

¾ To select the members of a group 

1. Select the group item whose members you want to select. 

2. From the Item menu, choose Select Group. 

The items that are members of the group are highlighted in the current view. 

Removing a Group 
When you remove a group, only the group definition is removed. No items or data values are 
deleted. 

¾ To remove a group 

1. Select the item whose group definition you want to remove. 

2. From the Item menu, choose Remove Group. 

The group type indicator is removed from the status bar. 

Calculating Group Totals 
Tip:  When calculating group totals, it saves time to define all groups in all dimensions before 
you run the Calculate command. 

Note: If two computed groups intersect, the result is 0. 
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¾ To calculate group totals 

1. From the View menu, choose Calculate. 

The Browser calculates and displays the group totals. 

Fields 
Fields are the components of a dimension. All fields of a dimension can be displayed in a 
dimension view. You can add, edit, delete, hide, or show fields. 

A field can be assigned a language so that, in a multilingual table, the appropriate language 
of the dimension displays.  

Fields can contain codes that uniquely identify an item, labels that describe an item, and 
coded links to a map file. 

Adding a Field 
Before you can add labels to a dimension, you must first add a field. 

¾ To add a field to a dimension 

1. Select the dimension that fields are to be added to. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

 A dimension view appears. 

3. From the Dimension menu, choose Add Field. 

 The Add Field dialog box appears. 

 
4. In Field Name, enter a name for the new field. 

 Note:  If you are adding a field to import labels, the field name must be identical to the 
field name in the import file. 

5. In Field Type, select Label. 

6. If you are in a multilingual table, enter or select the language of the field you want to add. 
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 Note: If you select a language other than that of the current table, the field is added to 
the appropriate table view and can only be seen when you are in a table or dimension 
view of that language. 

7. Do one of the following: 

• To display this field as a label in the table view, select the check box for Display as 
Data Label. 

• Clear the check box to prevent Browser users from seeing this field in the table view. 

8. Click OK. 

 The field is added to the dimension view. 

Deleting a Field 
¾ To delete a field from a dimension 

 Important:  You cannot delete the Code field. The Browser needs the Code field to 
uniquely identify each item in the dimension.  

1. Select the dimension that contains the field you want to delete. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

 The dimension view appears. 

3. Position the cursor in the field to be deleted. 

4. From the Dimension menu, choose Delete Field. 

 You are prompted to confirm the deletion. 

5. Click OK. 

Editing a Field 
¾ To edit a field in a dimension 

1. Select the dimension containing the field you want to edit. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

 The dimension view appears. 

3. Position the cursor in the field to be edited. 

4. From the Dimension menu, choose Edit Field. 

 The Edit Field dialog box appears. 
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5. In Field Name, enter a new field name.  

6. If your table is multilingual, enter or select the language of the field. 

7. Modify the Display as Data Label and Band Field options as required. 

8. Click OK. 

Hiding and Showing Fields 
You can control which fields are displayed in the table and dimension views by hiding and 
showing fields. 

¾ To hide or show fields 

1. Select the dimension containing the fields you want to hide or show. 

2. From the Dimension menu, choose Hide/Show Fields. 

 The Hide/Show Fields dialog box appears. 

  
3. In Select fields to be shown, select the fields you want to be visible. Deselect the fields 

that are to be hidden, and then click OK. 

Labels 
Labels can be entered manually or imported from a comma-separated value file, or a 
dimension definition file. You must prepare a comma-separated value file before importing 
labels into a dimension view. 
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Adding Labels Manually 
¾ To add labels manually 

1. Select the dimension you want to add labels to. 

2. Do one of the following: 

•  Click the Display Active Dimension button on the toolbar. 

• From the View menu, choose Dimension. 

3. If required, add a label field to the dimension that requires labels.  

4. In the label field, select the cell that requires a label. Enter the label and press Enter. 

 Tips:  You can set the action of the cursor on pressing Enter. To move the cursor down 
instead of across after pressing Enter - from the Window menu, choose Preferences and 
select Cursor Down after Cell Edit. 

 To edit a label after it has been entered, select the label and press F2. The item is 
highlighted. Make any required changes and press Enter. 

5. Repeat Step 4 for each cell in the field that requires a label. 

Preparing Labels in Comma-Separated Value Format 
Another way to import labels into a dimension is to prepare a comma-separated value file 
and import it into the field of a dimension view. Comma-separated value files are prepared 
outside of Beyond 20/20 and have a .csv extension. 

The comma-separated value file you create must contain a field whose values match those in 
a field that is already in the dimension view. This field is called the lookup field and is 
normally the Code field. The first line of the comma-separated value file should be the case 
sensitive names of the fields in the dimension, one of which must be the lookup field. 

For each row in the comma-separated value file, the Browser takes the field that you identify 
and uses it to search for a match in the lookup field of the dimension. When the Browser 
finds a match, it takes the corresponding label from the same row of the comma-separated 
value file and places it in the matching fields of the dimension that is being updated. 

You can use any editor or spreadsheet to create a comma-separated value file. These files 
contain the same number of fields in each row entry (as specified by the first line), delimited 
by commas, and each entry has a carriage-return and linefeed character at the end of it. 
Most spreadsheets packages allow you to save active spreadsheets in comma-separated 
value format. 

You can import more than one set of labels by including several sets in the comma-separated 
value file. 

Here is an example of a comma-separated value file: 
 
Code,English Desc 
NA,North America 
CA,Canada 
MA,Maritimes 
QU,Quebec 
ON,Ontario 
TO,Toronto 



 115

¾ To prepare a comma-separated value file from a spreadsheet 

1. In the first row of your spreadsheet, enter the field names as they appear in the 
dimension view of the field you are importing labels into (i.e., the lookup field). 

 Example: Enter Code in cell A1 and Label in cell B1. 

2. In the Code column, enter the complete set of item codes for the dimension you are 
importing labels into. 

3. In the Label column, enter the corresponding labels. 

4. From the File menu of your spreadsheet program, choose Save As. 

 The Save As dialog box appears. 

5. In File name, enter or select the file you want to save. If you do not see the file you want, 
select a different drive or directory to locate the file. 

6. Select comma-separated value (*.csv) as the file type. 

7. Click OK. 

Importing Labels 
You can bring labels into a field of a dimension view from a comma-separated value file or a 
dimension definition file. 

Before using the Import command, you must first prepare a file for import. For information on 
preparing a .csv file, refer to To prepare a comma-separated value file from a spreadsheet. 

In all cases, it is important to remember that the lookup field name (the field name in the 
dimension containing values) must match a field name in the input file (the comma-separated 
value file containing the labels to be imported). 

 Note:  You must be in a dimension view to import labels. 

1. If required, add a label field to the dimension that requires labels.  

 Note:  The new field name in the dimension must be identical to the field name in the 
input file that contains the labels you are importing. 

4. From the File menu, choose Import. 

 
3. Do one of the following: 

• In Input Filename, enter the path and file name of the file to import. 

• Click Browse to locate and select the file to import. 
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4. In Lookup Field, select the field the Browser should use to match items with those in the 
input file. 

5. In the Import Options area: 
Select If you want the Browser to 
Add New Codes add new codes from the input file into the dimension. 
Case Sensitive on 
Codes 

import only those items that are an exact match to the 
codes in the lookup field.  

Use Windows 
Character Set 

import the file as ANSI standard characters rather 
than OEM (DOS) characters. 

6. Click OK. 

 The label field is filled with labels for those items in the input file that are also in the 
dimension. 

Setting the Default Label Field 
When you set a field as the default label field, you are controlling which labels are seen when 
a table is first opened. 

¾ To set the default label field 

1. Select the dimension you want to set default label fields for. 

2. Do one of the following: 

•  Click the Next Label button on the toolbar. 

• From the Dimension menu, choose Change Labels. 

 If you save the view, the next time you open this table this dimension will display the set 
of labels you selected. 

Saved Views 
A saved view is a particular view of a table that is stored in the table file (*.ivt) and defines 
how the table is displayed. It is a snapshot of a table that allows you to quickly recall a 
specific table layout without having to redefine its attributes. 

A Beyond 20/20 view consists of the following: 
Attribute Description 
Language The language in which to display the table. 
Dimension 
Information 

For each dimension, the dimension information consists of: 
the sort order of items, the items that are shown, the first 
item to display, the label field to use for each language in 
the table, the width of the row dimension label, and the 
width of the dimension bar dimension label. 

Row Dimensions The list of row dimensions in the order in which they are 
nested. 

Column Dimensions The list of column dimensions in the order in which they are 
nested. 

Dimension Bar 
Dimensions 

The list of the dimensions in the dimension bar, in the order 
(left to right) that they appear on the screen. 

Column Width The width of the data columns. 
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Decimals The number of decimals to display. 
Time Series Information The time series type, periodicity, method, and number of 

periods. 
Fiscal Month The current fiscal month. 

¾ To save the current view 

Note:  To permanently change the default view of a table, you must have permission to 
modify the table. 

1. Arrange the table information in the layout you wish to save. 

2. From the View menu, choose Save. 

 The next time you open the table, the saved view will appear by default. 

Note:  If you are in a read-only table, or if you do not want to permanently modify the default 
view of the table, or if you want to save multiple views of the same table, you can save the 
current view without affecting the original view of the table. 

1. Arrange the table information in the layout you want to save. 

2. From the File menu, choose Save As. 

 The Save As dialog box appears. 

3. In File name, enter the name of the file you want to save. If necessary, select a different 
drive or directory. 

4. Clear the Include Numeric Data check box. 

5. Click Save. 

 The current view of the table is saved as a new table file. 

 Notes:  Data is not saved with the view. When the view is opened from another table, 
Beyond 20/20 checks the consistency of the view with the current table. If consistent, the 
current table view is replaced with the view being opened. 

 You can locate saved views through the Find dialog box or the Open dialog box.  

¾ To open a saved view 

1. From the View menu, choose Open. 

 The Open dialog box appears 

2. Select the view file you want to open. 

3. If you do not see the file you want to open, select a different drive or directory to locate 
the file. 

4. Click OK. 

Beyond 20/20 checks the consistency of the view with the current table. If consistent, the 
current view is replaced with the view being opened. 

¾ To restore the current view to the last saved view 

1. From the View menu, choose Reset. 

Any changes you made to the current view are lost, and the table view is restored to the 
last saved view. 
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Documenting a Table 
Once a table has been created, you should document it. To document a table, enter a table 
summary and dimension and item summaries. 

Table Summary 
A table summary contains general information about a table, and is helpful in understanding 
the contents of the table. It might include information about where the data came from and 
how it was collected. 

To view a table summary, click Summary in the File menu. 

¾ To create a table summary 

1. From the Edit menu, point at Summary and then choose File. 

 The Summary dialog box appears. 

 
2. Enter the following information: 

Box Summary information 
Title A description of the table. 
Category A subject area classification for the table. 
Author The author of the table. 
Keywords Words that can be entered to search for the table.  
Notes Any notes you wish to associate with the table that can make 

the table more understandable. Notes can be entered in 
HTML format and can include hyperlinks.  

3. Click OK. 
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Dimension Summary 
A dimension summary contains notes about a dimension. To view a dimension summary, 
click the summary icon  beside a dimension name. 

¾ To enter a dimension summary 

1. Select the dimension you want to add notes to. 

2. From the Edit menu, point at Summary and then choose Dimension. 

 The Dimension Summary dialog box appears. 

3. Enter any notes you want to associate with the dimension that may make the dimension 
more understandable. Notes can be entered in HTML format and can include hyperlinks.  

4. Click OK. 

Item Summary 
An item summary contains notes about a specific item within a dimension. It may explain any 
anomalies in the data, or give specific details about the item. To view an item summary, click 
the summary icon  beside an item name. 

¾ To enter an item summary 

1. Select the item you want to add notes to. 

2. From the Edit menu, point at Summary and then choose Item. 

 The Item Summary dialog box appears. 

3. Enter any notes you want to associate with the item that may make the item more 
understandable. Notes can be entered in HTML format and can include hyperlinks.  

4. Click OK. 

HTML in Summaries 
You can use HTML in the Notes area of summaries for formatting and creating hyperlinks. 
However, Beyond 20/20 urges caution. See Notes on HTML in Summaries, below, for more 
information.  

• Only use HTML if there is a strong requirement for its features. 

• Only use simple text formatting tags. 

• Only use absolute links. 

Note: To include a simple hyperlink in your notes, you do not have to define the notes as an 
HTML document with opening and closing tags (<HTML></HTML>). Simply code the 
hyperlink as an absolute path in the form: 

<A HREF="http://server_domain_name/path_name/page.html">link name</A> 

Only hyperlinks work in this way. Other HTML coding will not work and the code will be 
visible to the viewer. 

Notes on HTML in summaries 
Beyond 20/20 urges you to use caution when deciding whether to use HTML in summaries. 
Some of the issues regarding the use of HTML in summaries are as follows: 
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• HTML merges formatting codes and content in a single document. Before you can 
export data to other file formats or view the contents in a non-HTML viewer, the 
codes and content must first be separated. This separation process can make 
summary notes difficult to read, confusing, or incorrect. 

• Because Beyond 20/20’s IVT format is self-contained, IVTs can be moved to 
another location, downloaded, published using the Web Data Server (WDS), or 
installed from a CD-ROM in an unknown location with no loss of information. When 
relative links or image files are used the IVT is no longer self-contained but is tied to 
a remote reference. Relative links will fail if you move an IVT without moving all the 
linked files at the same time.   

• Similarly, links will fail in the Web Data Server if you have not maintained the original 
relationship between the IVT and the referenced document. Links will also fail if 
operating system security has not been set properly to permit access to the 
specified files. For example, a summary may display properly in an intranet 
environment but fail when the same file is published to the Internet, even though its 
location is the same. 

• The relationship of relative links within an IVT to the source document is a complex 
one. Please read the  topic, below, for information on specialized Beyond 20/20 links 
and links that will work with the Web Data Server. 

• Viewing summaries in HTML relies on an external program (the web browser), over 
which Beyond 20/20 has no control. HTML may display properly on some computers 
but show different formatting or lost content on other computers. Users’ 
configuration settings may affect the display of summaries that use certain HTML 
features. Also, future web browser releases may contain code changes or bugs that 
cause the HTML to display incorrectly. 

• When HTML is used in summaries, Beyond 20/20 assumes a requirement to display 
the summary exactly as it is specified, and we minimize any changes to the 
generated document. On the other hand, if summaries are stored as text, Beyond 
20/20 can format the text appropriately for the end-user. For example, in future 
releases, WDS may be able to offer centralized administration to give web sites a 
standardized look and feel based on the corporate web site. It may also be possible 
to add or remove new information content into the summaries. This feature will not 
be available if HTML has been used in the summaries. It is difficult to know what 
changes, features and environments will be required in the years ahead. Avoiding 
HTML if it is not required offers the best path to being able to take advantage of 
those features. 

The Summary Editor 
In the summary editor’s default state the “Use HTML Editor for Summary” checkbox is 
unchecked and the formatting tools in the toolbar are grayed out:  
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In this state you can enter notes in the Notes area either in plain text or as HTML code. In 
order to use HTML you must place the following tag at the start of your code: 

<META name=’B2020-Summary’ Content=’None’> 

This tag prevents the information in the specialized text boxes (Title, Category, etc.) from 
being included in your summary. Therefore, if you want to include such information you will 
have to place it in the body of your notes.  

The HTML Editor 
If you would prefer to use a WYSIWYG HTML editor for entering notes in HTML, you can 
check “Use HTML Editor for Summary.”  

A caution message will appear. Please read it carefully and refer to the Notes on HTML in 
summaries, above. Then if you decide to proceed, the formatting tools will become active. 

Note:  To use the HTML editing tools described here you must have Internet 
Explorer 5.0 or later installed on your computer. 
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The HTML editor automatically inserts the following tag in the Notes area: 

<META name=’B2020-Summary’ Content=’None’> 

As above, this tag prevents the information in the specialized text boxes (Title, Category, 
etc.) from being included as part of the summary. Therefore if you want your summary to 
include that information, you will have to enter it into the summary body. 

The HTML editing tools are described below: 

Editing tools 
Tool Purpose 

 Applies a font from the drop-down list to selected text in 
the Notes area. 

 Applies a font size from the drop-down list to selected text 
in the Notes area. 

 
Applies an HTML format from the drop-down list to 
selected text in the Notes area. Formats are as follows: 

• Normal 

• Formatted 

• Address 

• Heading 1 to Heading 6 

• Numbered list 

• Bulleted list 

• Directory list 

• Menu list 

• Definition term 



 123

• Definition 

• Paragraph 

 
Applies a Bold, Italic, or Underline character format to 
selected text in the Notes area. 

 
Applies Default, Left, Center, or Right alignment to the 
selected text or graphic element in the Notes area. 

 
Applies a color from the drop-down list to selected text in 
the Notes area. 

 
Applies a highlight color from the drop-down list to the 
selected text in the Notes area. 

 
Opens the  (below) so you can insert a graphic image at 
the cursor location in the Notes area. 

 
Opens the  (below) so you can insert a link from the 
selected text or graphic item in the Notes area. 

 
Opens the  (below) so you can place a table at the cursor 
position in the Notes area. 

 Selects normal or HTML view in the Notes area. Normal 
view is a WYSIWYG editor that automatically creates 
HTML codes. HTML view allows you to enter HTML codes 
directly. 

Picture dialog box 

 
Enables you to insert a graphic image into the Notes area. (Images must be in either .GIF or 
.JPG format.) 

Options 
Picture Source Enter or browse to the location of the image you want to 

insert. 

Hyperlink dialog box 
Enables you to enter the internet address for a simple hyperlink.  
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Options 
Type Select http:. Only absolute links of the type http:// can 

safely be used in Beyond 20/20 summaries.  
URL Enter the internet address of the location your hyperlink will 

point to. Note that the prefix (http://) is already entered. 

Insert Table dialog box 
Allows you to place a table in the Notes area of your summary. 

 
Options 
Size Enter or select the number of rows and columns in your 

table. 
Alignment Align your table to the Left, Center, or Right. 
Border size Select a size in pixels for your table’s cell borders. Select 

“0” for no borders. 
Cell padding Select a distance in pixels from your table’s data to the cell 

borders. 
Cell spacing Select a space in pixels between the cells of your table. 

Select “0” for no gap between the cells. 
Specify width Check to specify a width for your table in pixels or percent. 

If unchecked the table resizes itself to fit its contents. The 
width of the Beyond 20/20 summary Notes area is about 
400 pixels; choose 100% if you want your table to fill the 
entire width. If you choose a size that is wider than the 
window, a horizontal scroll bar appears. 

Hyperlinks 
Beyond 20/20 Builder and Browser products have the ability to use specialized codes to 
reference files on an intranet or a local computer. Those codes are not supported by the 
newer Web Data Server, which must use absolute links. Both usages are described below: 
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Hyperlinks for use with the Web Data Server 
Use only the following kinds of links: 
 
Absolute path over network 
<A HREF="http://server_domain_name/path_name/page.html"> 
UNC-specified path 
<A HREF="\\machine\path\page.html"> 
Relative path 
<A HREF="page.html"> 
<A HREF="../directory/page.html"> 

Hyperlinks for use with Builder and Browser products 

Simple links 

Use the following specialized code to link to a file that you know to be located in the current 
directory of the user’s computer: 
 
<A HREF="file:link.htm"></A> 

Note that there are no forward slashes after “file:” as there would be in standard HTML. 

Complex links 

The file you want to link to might be stored on a CD-ROM, in a directory elsewhere on the 
user's hard drive, or on an intranet. In that case Beyond 20/20 has to resolve the actual 
location of the file when the link is clicked.  

The format to link to a file in an undefined location is as follows: 
 
<A HREF="File:B2020?Type,Product,Key,Info"></A> 

File:B2020? indicates that the file to be linked to is a local file whose location has not yet 
been determined. The other parameters refer to entries in the Product section of the user's 
B2020.ini file: 

 
Parameter Description 
Type The type of file being linked to. The type affects the information 

that is provided in the Info parameter, below. Possible values 
for Type and the meanings of the values are: 

• File – The file is a browser-supported document such 
as a text file, an HTML file, or a graphic. 

• Exec – The file is an executable file, and therefore an 
application must be launched in order to access it. 

Product The name of the product section in the B2020.ini file that 
contains the preferences for the product. 

Key The key in the Product section of B2020.ini that defines the 
application that is to be invoked. The key can have two 
comma-separated values: 

• The application to be invoked 
• An optional user-defined field that may be included in 
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the link via the %s substitution parameter 
Info Either the name of a file to view or of an executable to run, 

depending on the Type specified in the first parameter (above). 

• If the value of Type is File, Info contains the name of the 
file to be viewed in the user's browser. 

• If the value of Type is Exec, Info contains the command 
line information for running the executable. This may 
contain the characters %s, which indicate the second 
parameter of the key. 

Example 1 

This example shows you how to invoke a search engine from within a Beyond 20/20 
summary dialog. 

The name of your product is SocData. The search engine is called VIP.EXE. The command 
line for VIP.EXE requires you to specify the location of the database you want to search. 

At the time when the table's Summary Dialogs are prepared, you do not known where the 
user has installed the VIP application or the database. 

The following Product key in the B2020.ini file, created as part of the installation process for 
SocData, defines the location of the VIP executable in English and in French. It also defines 
the location of the database you want VIP to search. 

[SocData]  
VIPeng=c:\vip\vip.exe,d:\database\english  
VIPfra=c:\vip\vip.exe,d:\database\francais 

Within the File Summary notes, you can create a link as follows: 

Here is an <A HREF="File:B2020?Exec,SocData,VIPeng, -Qeconomic -
I%sSOCDATA.NFO">economic</A> link. 

This line of code appears this way to the user: 

Here is an economic link. 

In French, the link would be as follows: 

Ici est une connection <A HREF="File:B2020? Exec,SocData,VIPfra,-Qeconomique -
I%sSOCDATA.NFO">economique</A>. 

This line of code appears this way to the user: 

Ici est une connection economique. 

At run-time, when Beyond 20/20 encounters a link that contains the string "File:B2020?", it 
will look up the product section (SocData) and key (VIPeng) in the B2020.ini file. Then it will 
build the following command string: 

c:\vip\vip.exe -Qeconomic -Id:\database\socdata.nfo 

 Notes: 
The keys you choose to create in the Product section of B2020.ini are entirely 
arbitrary, but you should make sure they do not conflict with other keys that are 
defined there, such as B2020Software, RecentN , UserData, etc. 

If the VIP application is closed, Beyond 20/20 will retain its Window order and will 
reappear. 

If the VIP application is capable of invoking Beyond 20/20, then Beyond 20/20 will 
recognize that a new copy is being invoked and will instead bring up the original copy 
with the new command line. 
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It is up to the installation program to ensure that the application has been properly 
installed and that the B2020.ini file has been properly updated.  

Example 2 

The name of your product is "SocData." 

You want to create a link within the File Summary to a file called DATADICT.TXT. This file 
will remain on the CD because of its large size. 

As part of the installation process for SocData, you create the following product section and 
keys in the B2020.ini file: 

[SocData]  
DataDictEng=d:\ddeng  
DataDictFra=d:\ddfra 

This tells Beyond 20/20 to look in d: for the English and French DataDict files. 

Then you can create the following link within the File Summary notes: 

Here are the <A 
HREF="File:B2020?File,SocData,DataDictEng,DATADICT.TXT">field 
definitions</A>. 

Now when Beyond 20/20 encounters a link containing the string "File:B2020?" it will load the 
following document: 

D:\DDENG\DATADICT.TXT 

by looking up the product section [SocData] and key (DataDictEng) in the B2020.ini file. 

This string will be loaded into the viewer from within Beyond 20/20. 

In the French notes, the reference would be: 

Ici sont les<A 
HREF="File:B2020?File,SocData,DataDictFra,DATADICT.TXT">définition du 
champs</A>. 

 Note: 
The amount of information that is provided in the B2020.ini file is up to you, the information 
provider. The information in this example could have been specified as follows: 

[SocData]  
DataDictEng=d:\ddeng\datadict.txt  
DataDictFra=d:\ddfra\datadict.txt 

and the link as follows: 

Here are the <A HREF="File:B2020?File,SocData, DataDictEng,">field 
definitions</A>.  
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Menu Commands 

File Menu 

Open... (File menu) 
Displays the Open dialog box which allows you to open an existing table, extract or 
dimension definition file. 

Alternatives: 
Click the Open File button on the toolbar. 

Select a file from the bottom of the File menu. 

Press Alt, F, O. 

Close (File menu) 
Closes all of the windows associated with the active table or extract. 

Alternative: 
Press Alt, F, C. 

Find... (File menu) 
Opens the Find dialog box which searches for and opens tables or extracts using the Beyond 
20/20 category selection feature. 

Alternatives: 
Click the Find button on the toolbar. 

Press Alt, F, F. 

Summary... (File menu) 
Opens the Summary view which displays descriptive information about the active table which 
you can view. 

Alternative: 
Press Alt, F, Y. 
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Import... (File menu) 
Opens the Import dialog box which initiates any of the following actions: 

• Imports labels into a dimension view from a comma-separated value or dimension 
definition file. 

• Updates an existing Beyond 20/20 table from another Beyond 20/20 table. 

Alternative: 
Press Alt, F, M. 

Save As... (File menu) 
Opens the Save As dialog box which initiates any of the following actions: 

• Saves all or part of an existing table as a new table. 

• Exports table data to other file formats. 

Alternative: 
Press Alt, F, A. 

Save Extract As... (File menu) 
Opens the Save As dialog box which initiates any of the following actions: 

• Creates an extract (from an existing extract) that contains data values from those records 
that match any specified constraints. 

• Exports an extract to dBASE III, SAS, or SPSS formats. 

Alternative: 
Press Alt, F, E. 

Page Setup (File menu) 
Opens the Page Setup dialog box so you can customize the appearance of printed table 
documents. You can change the horizontal and vertical space occupied by titles, labels, and 
data elements, select fonts, set text justification rules, and modify the contents of selected 
titles. 

Alternatives: 
Press Alt, F, G. 

Print Preview (File menu) 
Opens the Print Preview dialog box. 

Alternatives: 
In the Page Setup dialog box, click Print Preview. 

Press Alt, F, V. 

Print... (File menu) 
Opens the Print dialog box, which prints the active table, dimension, chart or map view. 

Alternatives: 
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Click the Print View button on the toolbar. 

Click the right mouse button in the active view and choose Print from the shortcut menu. 

Press Alt, F, P. 

Recreate Extract (Utilities - File menu) 
Opens the Recreate Extract dialog box which corrects a corrupt extract file or updates an 
extract file. 

Alternatives: 
Press Alt, F, T, X. 

Import Profile (Utilities - File menu) 
Opens the Import Dimension Profile dialog box which imports a list of codes in an ASCII file 
to create a dimension profile. 

Alternatives: 
Press Alt, F, T, I. 

Exit (File menu) 
Ends the current session. 

Alternatives: 
Double-click on the Control-menu box. 

Press Alt, F, X. 

1, 2, 3, 4 (File menu) 
Lists the names of the last four files opened. Select the file you want to open. 

Alternative: 
Press Alt, F, (File Number).  

Edit Menu 
For information about a command in the Edit menu, choose the appropriate command name 
from the following list: 

Copy (Edit menu) 
Copies a cell, chart view, map view, or one or more items to the Windows Clipboard. 

Alternatives: 
Click the right mouse button in the active view and choose Copy from the shortcut menu. 

Press Ctrl+C. 

Press Alt, E, C.  
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Paste (Edit menu) 
Pastes data values or text from the Windows Clipboard into various locations in a Beyond 
20/20 table. 

Alternatives: 
Press Ctrl+V. 

Press Alt, E, P. 

File... (Summary - Edit menu) 
Opens the Summary dialog box so you can add or edit descriptive information about the 
active table. 

Alternative: 
Press Alt, E, S, F. 

Dimension... (Summary - Edit menu) 
Opens the Dimension Summary dialog box so you can add or edit descriptive components 
about the active dimension. 

Note:  When a dimension name in a tile is underlined, a summary is associated with that 
dimension. 

Alternatives: 
Press Alt, E, S, D. 

Item... (Summary - Edit menu) 
Opens the Item Summary dialog box so you can add or edit descriptive information about the 
active item. 

Note:  When an item heading is underlined, a summary is associated with that item. 

Alternatives: 
Press Alt, E, S, I. 

Extract... (Summary - Edit menu) 
Opens the Extract Summary dialog box so you can add or edit descriptive information about 
the active extract. 

Alternative: 
Press Alt, E, S, E. 

Source Field... (Summary - Edit menu) 
Opens the Source Field Summary dialog box so you can add or edit descriptive information 
about the active source field. 

Alternatives: 
Press Alt, E, S, S. 
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View Menu 

Open... (View menu) 
Displays the Open dialog box which allows you to open an existing table view, replacing the 
current view with the view stored in another table file. 

Alternative: 
Press Alt, V, N. 

Save (View menu) 
Saves the current view of the table in the table file (*.ivt). 

Alternative: 
Press Alt, V, S. 

Reset (View menu) 
Restores the current view to the view contained in the table file. 

Alternative: 
Press Alt, V, E. 

Decimals (View menu) 
Changes the number of decimal places that appear after the decimal point in decimal 
fractions. Changing the number of decimal places will round the data to the nearest digit of 
accuracy specified. 

The setting applies only to the active table and remains in effect until you change the setting, 
or close the table without first saving the view. 

Alternative: 
Press Alt, V, L. 

Change Language (View menu) 
Displays the table in one of its alternate languages. Subsequent selections of this menu 
command display the table in its next available language. The status bar indicates which 
language you are currently viewing. 

This command is only available for multilingual tables. 

Alternatives: 
Press F9. 

Press Alt, V, H. 

Dimension (View menu) 
Displays a dimension view showing the code and label fields associated with the active 
dimension. A dimension always contains one field of codes, and it may contain one or more 
fields of labels.  

Alternatives: 
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Click the Display Fields button on the toolbar. 

Press Ctrl+D. 

Press Alt, V, D.  

Chart (View menu) 
Displays a chart view from the column and row dimensions in the active table. The chart view 
depends on the selections you make in the table view before the chart view is created.  

You can change the format of a chart view by changing the chart options. For more 
information, see the Chart Options dialog box. 

Alternatives: 
Click the Display Chart button on the toolbar. 

Click the right mouse button in the active view and choose Chart from the shortcut menu. 

Press Ctrl+G. 

Press Alt, V, C.  

Chart Options... (View menu) 
Opens the Chart Options dialog box which changes the type of chart on display in the active 
chart view. 

Alternatives: 
Click the right mouse button in the active view and choose Chart Options from the shortcut 
menu. 

Press Alt, V, P. 

Chart Link... (View menu) 
Opens the Chart Link dialog box which unlinks and links dimensions so that dynamic plotting 
can be canceled or resumed, respectively. 

Alternatives: 
Click the right mouse button in the active view and choose Chart Link from the shortcut 
menu. 

Press Alt, V, K. 

Switch Axes (View menu) 
Switches the dimension currently on display in the horizontal axis of a chart with the 
dimension displayed in the legend. 

Alternatives: 
Click the right mouse button in the active view and choose Switch Axes from the shortcut 
menu. 

Press Alt, V, X. 
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Map (View menu) 
Displays the active table in a map view. Map views are not available unless the active table 
has geographic data associated with it and the geographic dimension has been linked to a 
map file by the Builder. 

You can change the colors and influence whether labels and/or data values and cities are 
displayed in a map view by changing the map options. For more information, see the Map 
Options dialog box. 

Alternatives: 
Click the Display Map button on the toolbar. 

Press Ctrl+M. 

Press Alt, V, M.  

Map Options... (View menu) 
Opens the Map Options dialog box which allows you to select the details that are displayed in 
a map view. 

Alternatives: 
Click the right mouse button in the active view and choose Map Options from the shortcut 
menu. 

Press Alt, V, O.  

Zoom In (View menu) 
Displays any available details for regions that comprise a larger region.  

Alternatives: 
Double-click on the region label. 

Press Alt, V, I.  

Zoom Out (View menu) 
Displays the composite region, with the component regions concealed within (if the regions 
currently displayed are part of a larger region). Other areas adjacent to the composite region 
are also displayed. 

Alternatives: 
Double-click on white space in the map view (i.e., not on a region). 

Press Alt, V, Z. 

Restore (View menu) 
Restores a magnified map view to its original state. 

Alternatives: 
Click the right mouse button in the active view and choose Restore from the shortcut menu. 

Press Alt, V, R. 
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Set Active Dimension...(View menu) 
Opens the Set Active Dimension dialog box which allows you to select a dimension using the 
keyboard instead of the mouse pointer. 

Alternatives: 
Click on a dimension tile. 

Choose the name of a dimension from the Active Dimension box. 

Press Alt, V, A. 

Move Dimensions (View menu) 
Provides a keyboard alternative for moving a dimension tile. You must make the dimension 
active before choosing this command. (To make a dimension active using key sequences, 
from the View menu, choose Set Active Dimension.) 

Alternatives: 
Use the mouse pointer to rearrange the objects in a table view. 

Press Alt, V, V. 

Time Series... (View menu) 
Opens the Time Series dialog box which aggregates data according to the display frequency 
you select. 

Alternative: 
Press Alt, V, T. 

Fiscal Year... (View menu) 
Opens the Fiscal Year dialog box which allows you to select a month to represent the 
beginning of a fiscal year for the active table. 

Alternative: 
Press Alt, V, F.  

Distributions... (View menu) 
Opens the Distributions dialog box which computes row, column and total distributions for the 
values in a table. 

Alternative: 
Press Alt, V, B.  

Worksheet... (View menu) 
Opens the View Worksheet dialog box which allows you to save all or part of a table to a 
worksheet. 

Alternative: 
Press Alt, V, W. 
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Calculate (View menu) 
Calculates values for all items that are defined as total or computed groups. 

Alternative: 
Press Alt, V, U. 

Dimension Menu 
Commands in the Dimension menu operate on the active dimension.  

Summary... (Dimension menu) 
Opens the Dimension Summary view, which displays descriptive components about the 
active dimension. 

Alternatives: 
Double-click on the dimension tile. 

Click the right mouse button in the active window and choose Dimension Summary from the 
shortcut menu. 

Press Alt, D, Y. 

Sort... (Dimension menu) 
Opens the Sort dialog box, which changes the order of items displayed in a table or 
dimension view. 

Alternatives: 
Click the Sort Dimension button on the toolbar. 

Press Alt, D, T. 

Search... (Dimension menu) 
Opens the Search dialog box which: 

• Reduces the items displayed in the table view to only those that match the specified text 
or data. 

• Displays hidden items that match the specified text or data. 

• Moves the cursor to the first item in the view that matches the search criteria. 

Alternatives: 
Click on the Search Dimension button on the toolbar. 

Press Alt, D, R. 

Reverse (Dimension menu) 
Replaces all of the items on display in the active dimension with all of the items in the active 
dimension that are hidden. 

Alternative: 
Press Alt, D, V.  
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Show All (Dimension menu) 
Displays all of the hidden items associated with the active dimension. 

Alternatives: 
Click the right mouse button in the active window and choose Show All from the shortcut 
menu. 

Press Alt, D, L.  

Reset (Dimension menu) 
The Reset command initiates any of the following actions: 

• Displays all items of the active dimension in the table. 

• Restores the sort order of items (provided the view was not saved). 

• Resets the active cell of the active dimension. 

Alternative: 
Press Alt, D, E.  

Drill Down (Dimension menu) 
Displays any items assigned to a group. 

Alternative: 
Press Alt, D, D. 

Drill Up (Dimension menu) 
Displays the item that group members are assigned to along with any other group items at 
the same level. 

Alternative: 
Press Alt, D, U. 

Drill Back (Dimension menu) 
Displays the previous group view.   

Alternative: 
Click the Drill Back arrow in a dimension tile. (A Drill Back arrow only appears if you have 
previously drilled down in a group.) 

Change Labels (Dimension menu) 
Moves from one field in the dimension to the next (if more than one field is available). 

Alternatives: 
Click the Change Labels button on the toolbar. 

Press Alt, D, C.  
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Edit Dimension... (Dimension menu) 
Opens the Edit Dimension dialog box which changes the dimension name, description, and 
default labels for the dimension. 

Alternatives: 
Press Alt, D, M. 

Add Field... (Dimension menu) 
Opens the Add Field dialog box which adds a new field to the active dimension. Once you 
have added a field, you can enter or import labels as required. 

Alternative: 
Press Alt, D, I. 

Edit Field... (Dimension menu) 
Opens the Edit Field dialog box which changes the name and display attributes of the active 
dimension field. 

Alternative: 
Press Alt, D, F. 

Delete Field (Dimension menu) 
Deletes a field in a dimension. 

Alternative: 
Press Alt, D, D. 

Hide/Show Fields... (Dimension menu) 
Opens the Hide/Show Fields dialog box which controls which fields of a dimension are 
displayed in the dimension view and, consequently, which fields can be viewed by Browser 
users. 

Alternative: 
Press Alt, D, H. 

Load Profile (Dimension menu) 
Opens the Load Profile dialog box which selects, shows, or deletes a dimension profile. 

Alternative: 
Press Alt, D, P. 

Save Profile (Dimension menu) 
Opens the Save Dimension Profile dialog box which saves selected items as a profile. Once 
you have saved a dimension profile, you can select or show the profile through the Load 
Profile dialog box. 

Alternative: 
Press Alt, D, S. 
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Item Menu 
Commands in the Item menu operate on items of a dimension.  

Summary... (Item menu) 
Opens the Item Summary view, which displays descriptive information about the active item. 

Alternatives: 
Click the Summary icon in the item tile. 

Click the right mouse button in the active window and choose Item Summary from the 
shortcut menu. 

Press Alt, I, Y. 

Show (Item menu) 
Displays only those items you select in the table or dimension view. 

Alternatives: 
Click the right mouse button in the active window and choose Show from the shortcut menu. 

Press Alt, I, S.  

Hide (Item menu) 
Hides the items you select so that they are no longer displayed in the table or dimension 
view. 

Note: Hiding items does not delete them from a table. 

Alternatives: 
Click the right mouse button in the active view and choose Hide from the shortcut menu. 

Press Alt, I, H.  

Select All (Item menu) 
Selects all of the items in the active dimension. Hidden items associated with the active 
dimension are not selected. 

Alternative: 
Press Alt, I, A.  

Insert... (Item menu) 
Opens the Insert Item dialog box which inserts an item into the active dimension. 

Alternatives 
Press Insert. 

Press Alt, I, T. 

Delete Item (Item menu) 
Deletes items from the active dimension. 
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Alternative: 
Press Alt, I, L. 

Define Group... (Item menu) 
Opens the Define Group dialog box which adds an item that defines a group of items. It also 
determines whether or not data values for the group are to be calculated. 

Alternative: 
Press Alt, I, G. 

Remove Group (Item menu) 
Removes a group definition from the selected item. The item remains in the table, along with 
the values it had associated with it prior to the operation. 

Alternative: 
Press Alt, I, R. 

Select Group (Item menu) 
Highlights the members of the group item currently selected. 

Alternative: 
Press Alt, I, P. 

Cell Information (Item menu) 
Lists the dimensions and dimension decriptions that are associated with the selected cell. 

Alternative: 
Press Alt, I, C.  

Press Ctrl+L. 

Click the right mouse button in a cell and choose Cell Information from the shortcut menu. 

Data Menu 
The commands in the Data menu are not available unless an extract is open.  

Extract Summary... (Data menu) 
Opens the Extract Summary view which displays descriptive components about the active 
extract which you can view. 

Alternative: 
Press Alt, T, Y. 

Define Recode... (Data menu) 
Opens the Define Recode dialog box which creates a new source field that contains a 
redistribution of the items from an existing source field. The new field maintains any existing 
groups. 
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Alternatives: 
Click the right mouse button on the source field you want to recode and choose Define 
Recode from the shortcut menu. 

Press Alt, T, R. 

Define Bands... (Data menu) 
Opens the Define Bands dialog box which creates a new numeric or coded source field that 
defines ranges of data values from an existing numeric source field. 

Alternatives: 
Click the right mouse button on the source field you want to re-band and choose Define 
Bands from the shortcut menu. 

Press Alt, T, B. 

Define Derived Field... (Data menu) 
Opens the Define Derived Field dialog box which creates a new numeric source field 
calculated using arithmetic operations on existing source fields. 

Alternative: 
Press Alt, T, D. 

Find Source Field... (Data menu) 
Opens the Find Source Field dialog box which searches for a particular source field and, if 
found, makes that source field active. 

Alternative: 
Press Alt, T, F. 

Source Field Summary... (Data menu) 
Opens the Source Field Summary view which displays descriptive components about the 
active source field which you can view. 

Alternative: 
Click the right mouse button on a source field and choose Source Field Summary from the 
shortcut menu. 

Press Alt, T, M. 

Delete Source Field (Data menu) 
Deletes a source field from an extract. 

Alternatives: 
Click the right mouse button on the source field you want to delete and choose Delete Source 
Field from the shortcut menu. 

Press Alt, T, E. 
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Set Weight Field... (Data menu) 
Opens the Set Weight Field dialog box which allows you to select the numeric source field 
that contains numeric weighting factors to be used during the creation of a table or an extract.  

The weighting factor of each record is the number of times that the record is logically 
replicated when the table or extract is being built. 

Alternative: 
Press Alt, T, W. 

Record Constraints... (Data menu) 
Opens the Record Constraints view which initiates any of the following actions: 

• Imposes one or more constraints on the records of a source file during the creation of a 
table. 

• Imposes one or more constraints before creating a new extract. 

Alternative: 
Press Alt, T, C. 

Table Options... (Data menu) 
Opens the Table Options dialog box which allows you to set various options in the table 
being created. 

Alternative: 
Press Alt, T, I. 

Go (Data menu) 
Loads data into a table based on the information that is associated with the source field tiles 
you have arranged in the empty table view. 

Note: You must have at least two dimensions defining the new table before you can use this 
command. 

Alternatives: 
Click the Go button on the toolbar. 

Press Alt, T, G. 

Window Menu 
For information about a command in the Window menu, choose the appropriate command 
name from the following list: 

Tile Vertical (Window menu) 
Displays all open document windows side-by-side in a tile arrangement. 

Alternatives: 
Click the Tile button on the toolbar. 

Press Alt, W, T. 
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Tile Horizontal (Window menu) 
Displays all open document windows one above the other in a horizontal tile arrangement.  

Alternative: 
Press Alt, W, H. 

Cascade (Window menu) 
Displays document windows one behind the other in a cascade arrangement with the title bar 
of each window showing. 

Alternative: 
Press Alt, W, C.  

Arrange Icons (Window menu) 
Arranges all icons neatly along the bottom of the workspace. 

Alternative: 
Press Alt, W, I.  

Close All (Window menu) 
Closes all of the document windows in the workspace. 

Alternatives: 
Press Alt, W, A.  

Preferences... (Window menu) 
Opens the Preferences dialog box which provides you with a way to set up your working 
environment and to control presentation options. 

Alternative: 
Press Alt, W, P. 

1, 2, 3, 4, ...9 (Window menu) 
Lists all document windows currently open. Select the number representing the window you 
want to make active. 

Alternatives: 
Press Alt, W, (Number).  

Help Menu 
For information about a command in the Help menu, choose the appropriate command name 
from the list below. 

Notes: You can access help, without choosing a command from the Help menu, while you are 
working. 

For menu commands, choose the command, and while you are holding down the left mouse 
button, press F1. 



 144

For dialog boxes, when the dialog box is open, press F1 or click the Help button in the dialog 
box. 

Contents (Help menu) 
Displays the Beyond 20/20 On-line Help window, which is built upon the Microsoft Windows 
Help facility. On-line help can be accessed while you work. 

The Contents page provides you with a complete list of the main topics in the on-line 
documentation. When you click on a section in the list, the Help function takes you directly to 
that topic. 

Alternative: 
Press Alt, H, C. 

Search... (Help menu) 
Opens the Search dialog box which searches for a subject that you want more information 
about, and then links to a section in the on-line documentation. 

Alternative: 
Press Alt, H, S. 

How to Use Help (Help menu) 
Displays the How to Use Help window where you can find detailed reference information 
about how to use the Microsoft Windows Help facility. This information also applies to the 
Browser On-line Help. 

Alternative: 
Press Alt, H, H.  

About Beyond 20/20... (Help menu) 
Displays the About Beyond 20/20 dialog box where you can find copyright and version 
information about the Browser. 

Alternative: 
Press Alt, H, A. 
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